summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 385fde6c6034..8874fbf316a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:27:49 UTC 2016
pkgbase = ros-indigo-rqt-shell
pkgdesc = ROS - rqt_shell is a Python GUI plugin providing an interactive shell.
- pkgver = 0.3.12
+ pkgver = 0.3.13
pkgrel = 1
url = http://ros.org/wiki/rqt_shell
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
depends = ros-indigo-rqt-gui-py
@@ -14,8 +15,8 @@ pkgbase = ros-indigo-rqt-shell
depends = ros-indigo-qt-gui
depends = ros-indigo-rqt-gui
depends = python2-rospkg
- source = rqt_shell::git+https://github.com/ros-gbp/rqt_common_plugins-release.git#tag=release/indigo/rqt_shell/0.3.12-0
- md5sums = SKIP
+ source = ros-indigo-rqt-shell-0.3.13-0.tar.gz::https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/indigo/rqt_shell/0.3.13-0.tar.gz
+ sha256sums = 0b027a771eed34006fc61ff73ef9ddf1715e8e306fecd088c7cec7131757599c
pkgname = ros-indigo-rqt-shell
diff --git a/PKGBUILD b/PKGBUILD
index 0dd2b476d7ef..11226589a33e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgdesc="ROS - rqt_shell is a Python GUI plugin providing an interactive shell."
url='http://ros.org/wiki/rqt_shell'
pkgname='ros-indigo-rqt-shell'
-pkgver='0.3.12'
+pkgver='0.3.13'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-indigo-rqt-gui-py
@@ -21,10 +21,16 @@ ros_depends=(ros-indigo-rqt-gui-py
depends=(${ros_depends[@]}
python2-rospkg)
-_tag=release/indigo/rqt_shell/${pkgver}-${_pkgver_patch}
-_dir=rqt_shell
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/rqt_shell/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_common_plugins-release-release-indigo-rqt_shell-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/indigo/rqt_shell/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('0b027a771eed34006fc61ff73ef9ddf1715e8e306fecd088c7cec7131757599c')
build() {
# Use ROS environment variables