summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e20b36f8d2..0b08051400cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Jan 23 09:22:01 UTC 2016
+# Sun May 22 21:52:54 UTC 2016
pkgbase = ros-jade-qt-gui-py-common
pkgdesc = ROS - qt_gui_py_common provides common functionality for GUI plugins written in Python.
- pkgver = 0.2.29
+ pkgver = 0.2.30
pkgrel = 1
url = http://ros.org/wiki/qt_gui_py_common
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-jade-catkin
depends = ros-jade-python-qt-binding
depends = python2-rospkg
- source = qt_gui_py_common::git+https://github.com/ros-gbp/qt_gui_core-release.git#tag=release/jade/qt_gui_py_common/0.2.29-0
- md5sums = SKIP
+ source = ros-jade-qt-gui-py-common-0.2.30-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/jade/qt_gui_py_common/0.2.30-0.tar.gz
+ sha256sums = ce4633bfa6db2e91e78067b146d854b74f009af485b01ae186889682d6a8d912
pkgname = ros-jade-qt-gui-py-common
diff --git a/PKGBUILD b/PKGBUILD
index d1ab0acbd460..0dff85f476fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,30 @@ pkgdesc="ROS - qt_gui_py_common provides common functionality for GUI plugins wr
url='http://ros.org/wiki/qt_gui_py_common'
pkgname='ros-jade-qt-gui-py-common'
-pkgver='0.2.29'
+pkgver='0.2.30'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-jade-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-jade-python-qt-binding)
depends=(${ros_depends[@]}
python2-rospkg)
-_tag=release/jade/qt_gui_py_common/${pkgver}-${_pkgver_patch}
-_dir=qt_gui_py_common
-source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/jade/qt_gui_py_common/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="qt_gui_core-release-release-jade-qt_gui_py_common-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/jade/qt_gui_py_common/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ce4633bfa6db2e91e78067b146d854b74f009af485b01ae186889682d6a8d912')
build() {
# Use ROS environment variables