summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--cmake_fix.patch14
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f31502fed96..ea1d35632c88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 16 05:57:38 UTC 2017
+# Wed Sep 6 22:08:01 UTC 2017
pkgbase = ros-kinetic-opencv3
pkgdesc = ROS - OpenCV 3.x.
pkgver = 3.2.0
- pkgrel = 6
+ pkgrel = 7
url = http://opencv.org
arch = any
license = BSD
@@ -33,7 +33,9 @@ pkgbase = ros-kinetic-opencv3
depends = qt5-base
depends = libxt
source = ros-kinetic-opencv3-3.2.0-4.tar.gz::https://github.com/ros-gbp/opencv3-release/archive/release/kinetic/opencv3/3.2.0-4.tar.gz
+ source = cmake_fix.patch
sha256sums = 2e2e35fe81f5764915ec998eeb1a4fc82053b46862662bf2b291328436653237
+ sha256sums = 1549289a92fff0464bfa343756f15b087e625bdd3e6ac74674a5a75b7a15bfaf
pkgname = ros-kinetic-opencv3
diff --git a/PKGBUILD b/PKGBUILD
index e0c7ef78e413..a6c724029fab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-kinetic-opencv3'
pkgver='3.2.0'
_pkgver_patch=4
arch=('any')
-pkgrel=6
+pkgrel=7
license=('BSD')
ros_makedepends=()
@@ -47,8 +47,15 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="opencv3-release-release-kinetic-opencv3-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/opencv3-release/archive/release/kinetic/opencv3/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('2e2e35fe81f5764915ec998eeb1a4fc82053b46862662bf2b291328436653237')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/opencv3-release/archive/release/kinetic/opencv3/${pkgver}-${_pkgver_patch}.tar.gz"
+ cmake_fix.patch)
+sha256sums=('2e2e35fe81f5764915ec998eeb1a4fc82053b46862662bf2b291328436653237'
+ '1549289a92fff0464bfa343756f15b087e625bdd3e6ac74674a5a75b7a15bfaf')
+
+prepare() {
+ cd ${srcdir}
+ patch -p1 < cmake_fix.patch
+}
build() {
# Use ROS environment variables
diff --git a/cmake_fix.patch b/cmake_fix.patch
new file mode 100644
index 000000000000..e89f2522048b
--- /dev/null
+++ b/cmake_fix.patch
@@ -0,0 +1,14 @@
+--- a/opencv3-release-release-kinetic-opencv3-3.2.0-4/cmake/OpenCVCompilerOptions.cmake 2017-09-06 14:50:24.699220119 -0700
++++ b/opencv3-release-release-kinetic-opencv3-3.2.0-4/cmake/OpenCVCompilerOptions.cmake 2017-09-06 14:50:46.888873247 -0700
+@@ -18,9 +18,9 @@
+ message(STATUS "Unable to compile program with enabled ccache, reverting...")
+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${__OLD_RULE_LAUNCH_COMPILE}")
+ endif()
+- else()
+- message(STATUS "Looking for ccache - not found")
+ endif()
++ else()
++ message(STATUS "Looking for ccache - not found")
+ endif()
+ endif()
+