summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af4c9ac944be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 02:31:07 UTC 2017
+pkgbase = ros-kinetic-rqt-topic
+ pkgdesc = ROS - rqt_topic provides a GUI plugin for displaying debug information about ROS topics including publishers, subscribers, publishing rate, and ROS Messages.
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = http://ros.org/wiki/rqt_topic
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-rqt-gui-py
+ depends = ros-kinetic-rqt-gui
+ depends = ros-kinetic-python-qt-binding
+ depends = ros-kinetic-rostopic
+ depends = ros-kinetic-std-msgs
+ depends = python2-rospkg
+ source = ros-kinetic-rqt-topic-0.4.5-0.tar.gz::https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/kinetic/rqt_topic/0.4.5-0.tar.gz
+ sha256sums = 8de618c0d5a7ab562f1b0ebee000d1a0efa22ee2fd9fbc53bd765ab1527b4f5a
+
+pkgname = ros-kinetic-rqt-topic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9c411c5c353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_topic provides a GUI plugin for displaying debug information about ROS topics including publishers, subscribers, publishing rate, and ROS Messages."
+url='http://ros.org/wiki/rqt_topic'
+
+pkgname='ros-kinetic-rqt-topic'
+pkgver='0.4.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rqt-gui-py
+ ros-kinetic-rqt-gui
+ ros-kinetic-python-qt-binding
+ ros-kinetic-rostopic
+ ros-kinetic-std-msgs)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rqt_topic/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_common_plugins-release-release-kinetic-rqt_topic-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/kinetic/rqt_topic/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('8de618c0d5a7ab562f1b0ebee000d1a0efa22ee2fd9fbc53bd765ab1527b4f5a')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}