summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a97565a30a1..8739f087cc3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 10:47:40 UTC 2017
+# Thu Aug 17 18:55:02 UTC 2017
pkgbase = ros-lunar-rosmaster
pkgdesc = ROS - ROS Master implementation.
- pkgver = 1.13.1
+ pkgver = 1.13.2
pkgrel = 1
url = http://ros.org/wiki/rosmaster
arch = any
@@ -12,8 +12,8 @@ pkgbase = ros-lunar-rosmaster
makedepends = ros-lunar-catkin
depends = ros-lunar-rosgraph
depends = python2-defusedxml
- source = ros-lunar-rosmaster-1.13.1-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rosmaster/1.13.1-0.tar.gz
- sha256sums = 67e5c2e2b1a8a54f5e26be84d4e94803aaef521882abb0c0f2f51042bea75911
+ source = ros-lunar-rosmaster-1.13.2-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rosmaster/1.13.2-0.tar.gz
+ sha256sums = a37bd6a4dfb9f95663dc75b07ee6df891484a94e5d5548c3b4396b3d18ca5c8d
pkgname = ros-lunar-rosmaster
diff --git a/PKGBUILD b/PKGBUILD
index 5e5bc7862171..b66bef548eba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - ROS Master implementation."
url='http://ros.org/wiki/rosmaster'
pkgname='ros-lunar-rosmaster'
-pkgver='1.13.1'
+pkgver='1.13.2'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -27,7 +27,7 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="ros_comm-release-release-lunar-rosmaster-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rosmaster/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('67e5c2e2b1a8a54f5e26be84d4e94803aaef521882abb0c0f2f51042bea75911')
+sha256sums=('a37bd6a4dfb9f95663dc75b07ee6df891484a94e5d5548c3b4396b3d18ca5c8d')
build() {
# Use ROS environment variables
@@ -35,14 +35,14 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \