summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD67
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc2f366fe656
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Mon May 22 17:06:31 UTC 2017
+pkgbase = ros-lunar-rqt-robot-dashboard
+ pkgdesc = ROS - rqt_robot_dashboard provides an infrastructure for building robot dashboard plugins in rqt.
+ pkgver = 0.5.7
+ pkgrel = 1
+ url = http://wiki.ros.org/rqt_robot_dashboard
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ depends = ros-lunar-qt-gui
+ depends = ros-lunar-rqt-console
+ depends = ros-lunar-diagnostic-msgs
+ depends = ros-lunar-rospy
+ depends = ros-lunar-rqt-nav-view
+ depends = ros-lunar-rqt-robot-monitor
+ depends = ros-lunar-python-qt-binding
+ depends = ros-lunar-rqt-gui-py
+ depends = ros-lunar-rqt-gui
+ source = ros-lunar-rqt-robot-dashboard-0.5.7-0.tar.gz::https://github.com/ros-gbp/rqt_robot_dashboard-release/archive/release/lunar/rqt_robot_dashboard/0.5.7-0.tar.gz
+ sha256sums = bd5df61568d54f6ecd2b7826f6ef9f39bae40d53dc9d46c0984ee7eba2e7501f
+
+pkgname = ros-lunar-rqt-robot-dashboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3036c87a6a6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_robot_dashboard provides an infrastructure for building robot dashboard plugins in rqt."
+url='http://wiki.ros.org/rqt_robot_dashboard'
+
+pkgname='ros-lunar-rqt-robot-dashboard'
+pkgver='0.5.7'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-qt-gui
+ ros-lunar-rqt-console
+ ros-lunar-diagnostic-msgs
+ ros-lunar-rospy
+ ros-lunar-rqt-nav-view
+ ros-lunar-rqt-robot-monitor
+ ros-lunar-python-qt-binding
+ ros-lunar-rqt-gui-py
+ ros-lunar-rqt-gui)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rqt_robot_dashboard/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_robot_dashboard-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_robot_dashboard-release-release-lunar-rqt_robot_dashboard-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_robot_dashboard-release/archive/release/lunar/rqt_robot_dashboard/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('bd5df61568d54f6ecd2b7826f6ef9f39bae40d53dc9d46c0984ee7eba2e7501f')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}