summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5d50678a84c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Aug 14 11:04:54 UTC 2017
+pkgbase = ros-lunar-unique-id
+ pkgdesc = ROS - ROS Python and C++ interfaces for universally unique identifiers.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = http://ros.org/wiki/unique_id
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-lunar-catkin
+ makedepends = ros-lunar-roscpp
+ makedepends = ros-lunar-rospy
+ makedepends = ros-lunar-uuid-msgs
+ depends = ros-lunar-roscpp
+ depends = ros-lunar-rospy
+ depends = ros-lunar-uuid-msgs
+ source = ros-lunar-unique-id-1.0.6-0.tar.gz::https://github.com/ros-geographic-info/unique_identifier-release/archive/release/lunar/unique_id/1.0.6-0.tar.gz
+ sha256sums = e45fcbeaabf28d27cc227a46aaa801fa1b33d5da775556cfa8e132c080aaf230
+
+pkgname = ros-lunar-unique-id
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..396842b4d301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - ROS Python and C++ interfaces for universally unique identifiers."
+url='http://ros.org/wiki/unique_id'
+
+pkgname='ros-lunar-unique-id'
+pkgver='1.0.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-roscpp
+ ros-lunar-rospy
+ ros-lunar-uuid-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-roscpp
+ ros-lunar-rospy
+ ros-lunar-uuid-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/unique_id/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-geographic-info/unique_identifier-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="unique_identifier-release-release-lunar-unique_id-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-geographic-info/unique_identifier-release/archive/release/lunar/unique_id/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e45fcbeaabf28d27cc227a46aaa801fa1b33d5da775556cfa8e132c080aaf230')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
+
+ # Build project
+ cmake "${srcdir}/${_dir}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}