summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD70
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e721e6082edd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ros-melodic-easy-markers
+ pkgdesc = ROS - Python library to assist in publishing markers easily.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://ros.org/wiki/easy_markers
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-tf
+ makedepends = ros-melodic-interactive-markers
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-roslib
+ makedepends = ros-melodic-geometry-msgs
+ makedepends = ros-melodic-visualization-msgs
+ makedepends = ros-melodic-rospy
+ depends = ros-melodic-tf
+ depends = ros-melodic-interactive-markers
+ depends = ros-melodic-roslib
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-visualization-msgs
+ depends = ros-melodic-rospy
+ source = ros-melodic-easy-markers-0.2.4-0.tar.gz::https://github.com/wu-robotics/wu_ros_tools/archive/release/melodic/easy_markers/0.2.4-0.tar.gz
+ sha256sums = 64fea822e5e6ee2d58d4bfbd23519485c3197e5a8a8d74ef97ec91abc5e35088
+
+pkgname = ros-melodic-easy-markers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35e29058e444
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Python library to assist in publishing markers easily."
+url='http://ros.org/wiki/easy_markers'
+
+pkgname='ros-melodic-easy-markers'
+pkgver='0.2.4'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-tf
+ ros-melodic-interactive-markers
+ ros-melodic-catkin
+ ros-melodic-roslib
+ ros-melodic-geometry-msgs
+ ros-melodic-visualization-msgs
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-tf
+ ros-melodic-interactive-markers
+ ros-melodic-roslib
+ ros-melodic-geometry-msgs
+ ros-melodic-visualization-msgs
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/easy_markers/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/wu-robotics/wu_ros_tools.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="wu_ros_tools-release-melodic-easy_markers-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/wu-robotics/wu_ros_tools/archive/release/melodic/easy_markers/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('64fea822e5e6ee2d58d4bfbd23519485c3197e5a8a8d74ef97ec91abc5e35088')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}