summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--CMakeLists-signal.patch11
-rw-r--r--PKGBUILD20
3 files changed, 9 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00bb0410b882..9722e30a7e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-tf2
pkgdesc = ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time.
- pkgver = 0.6.5
- pkgrel = 2
+ pkgver = 0.6.6
+ pkgrel = 4
url = https://www.wiki.ros.org/tf2
arch = any
license = BSD
@@ -16,10 +16,8 @@ pkgbase = ros-melodic-tf2
depends = ros-melodic-tf2-msgs
depends = ros-melodic-geometry-msgs
depends = console-bridge
- source = ros-melodic-tf2-0.6.5.tar.gz::https://github.com/ros/geometry2/archive/0.6.5.tar.gz
- source = CMakeLists-signal.patch
- sha256sums = 9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a
- sha256sums = 878047021778a148cac5a2a6f04e8ee45df593f294022db053d42bc7e5692dbd
+ source = ros-melodic-tf2-0.6.6.tar.gz::https://github.com/ros/geometry2/archive/0.6.6.tar.gz
+ sha256sums = 4955f3ca30d194b0e0842f59b97a72d0e933908c20c56c8c374c152ab02568d1
pkgname = ros-melodic-tf2
diff --git a/CMakeLists-signal.patch b/CMakeLists-signal.patch
deleted file mode 100644
index b948e26aced1..000000000000
--- a/CMakeLists-signal.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.old 2019-05-24 23:35:56.152546901 -0400
-+++ CMakeLists.txt 2019-05-24 23:36:06.709213096 -0400
-@@ -3,7 +3,7 @@
-
- find_package(console_bridge REQUIRED)
- find_package(catkin REQUIRED COMPONENTS geometry_msgs rostime tf2_msgs)
--find_package(Boost REQUIRED COMPONENTS signals system thread)
-+find_package(Boost REQUIRED COMPONENTS system thread)
-
- catkin_package(
- INCLUDE_DIRS include
diff --git a/PKGBUILD b/PKGBUILD
index 1d66a2d549c2..91b57fee40ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@ pkgdesc="ROS - tf2 is the second generation of the transform library, which lets
url='https://www.wiki.ros.org/tf2'
pkgname='ros-melodic-tf2'
-pkgver='0.6.5'
+pkgver='0.6.6'
arch=('any')
-pkgrel=2
+pkgrel=4
license=('BSD')
ros_makedepends=(
@@ -35,15 +35,8 @@ depends=(
)
_dir="geometry2-${pkgver}/tf2"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/geometry2/archive/${pkgver}.tar.gz"
- CMakeLists-signal.patch)
-sha256sums=('9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a'
- '878047021778a148cac5a2a6f04e8ee45df593f294022db053d42bc7e5692dbd')
-
-prepare() {
- cd "${srcdir}/${_dir}"
- patch -uN CMakeLists.txt ../../../CMakeLists-signal.patch || return 1
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/geometry2/archive/${pkgver}.tar.gz")
+sha256sums=('4955f3ca30d194b0e0842f59b97a72d0e933908c20c56c8c374c152ab02568d1')
build() {
# Use ROS environment variables.
@@ -63,10 +56,7 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DBOOST_ROOT=/opt/boost1.69
make
}