summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD103
2 files changed, 48 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c2c4143dd40..95ac650c2b41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,16 +8,16 @@ pkgbase = ros-melodic-tf2
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-tf2-msgs
makedepends = ros-melodic-geometry-msgs
makedepends = ros-melodic-rostime
- makedepends = ros-melodic-tf2-msgs
makedepends = console-bridge
+ depends = ros-melodic-tf2-msgs
depends = ros-melodic-geometry-msgs
depends = ros-melodic-rostime
- depends = ros-melodic-tf2-msgs
depends = console-bridge
- source = ros-melodic-tf2::git+https://github.com/ros-gbp/geometry2-release.git
- sha256sums = SKIP
+ source = ros-melodic-tf2-0.6.3-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2/0.6.3-0.tar.gz
+ sha256sums = 6e27c4842b75f4a0855ce5768b5b8a0ee3a1f26f061b21c38de83d6e6916b9c1
pkgname = ros-melodic-tf2
diff --git a/PKGBUILD b/PKGBUILD
index 2820636cdda6..d56e9f4e93d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time."
url='http://www.ros.org/wiki/tf2'
@@ -10,72 +10,57 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
- ros-melodic-geometry-msgs
- ros-melodic-rostime
- ros-melodic-tf2-msgs
-)
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-tf2-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-rostime)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ console-bridge)
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
- console-bridge
-)
+ros_depends=(ros-melodic-tf2-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-rostime)
+depends=(${ros_depends[@]}
+ console-bridge)
-ros_depends=(
- ros-melodic-geometry-msgs
- ros-melodic-rostime
- ros-melodic-tf2-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/tf2/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- console-bridge
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="geometry2-release-release-melodic-tf2-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('6e27c4842b75f4a0855ce5768b5b8a0ee3a1f26f061b21c38de83d6e6916b9c1')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}