summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD101
2 files changed, 62 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e52e5325766a..a775f9f2bfed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,14 +9,14 @@ pkgbase = ros-melodic-tf2-eigen
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
makedepends = ros-melodic-tf2
- makedepends = ros-melodic-geometry-msgs
makedepends = ros-melodic-cmake-modules
+ makedepends = ros-melodic-geometry-msgs
makedepends = eigen3
- depends = ros-melodic-tf2
depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-tf2
depends = eigen3
- source = ros-melodic-tf2-eigen-0.6.3-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_eigen/0.6.3-0.tar.gz
- sha256sums = a5b888eb955c7663698c4785092512af3e80cb886d10df3ae3ef5ed6598a67f2
+ source = ros-melodic-tf2-eigen::git+https://github.com/ros-gbp/geometry2-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-tf2-eigen
diff --git a/PKGBUILD b/PKGBUILD
index 2d5d3b7dc878..6c2cb6ac9d4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - tf2_eigen."
url='http://www.ros.org/'
@@ -10,56 +10,71 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin
- ros-melodic-tf2
- ros-melodic-geometry-msgs
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- eigen3)
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-tf2
+ ros-melodic-cmake-modules
+ ros-melodic-geometry-msgs
+)
-ros_depends=(ros-melodic-tf2
- ros-melodic-geometry-msgs)
-depends=(${ros_depends[@]}
- eigen3)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ eigen3
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/tf2_eigen/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-geometry-msgs
+ ros-melodic-tf2
+)
-# Tarball version (faster download)
-_dir="geometry2-release-release-melodic-tf2_eigen-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_eigen/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('a5b888eb955c7663698c4785092512af3e80cb886d10df3ae3ef5ed6598a67f2')
+depends=(
+ ${ros_depends[@]}
+ eigen3
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}