summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d343d42f54..eaf423c77c85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-tuw-multi-robot-msgs
pkgdesc = ROS - The tuw_multi_robot_msgs package.
pkgver = 0.0.13
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/tuw_multi_robot_msgs
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 3d1f5ac0843f..34d97fdd1956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/tuw_multi_robot_msgs'
pkgname='ros-melodic-tuw-multi-robot-msgs'
pkgver='0.0.13'
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-melodic-catkin
@@ -37,17 +37,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}