summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD69
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc1685fbad99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ros-melodic-urdf-sim-tutorial
+ pkgdesc = ROS - The urdf_sim_tutorial package.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-position-controllers
+ depends = ros-melodic-controller-manager
+ depends = ros-melodic-joint-state-controller
+ depends = ros-melodic-diff-drive-controller
+ depends = ros-melodic-urdf-tutorial
+ depends = ros-melodic-gazebo-ros-control
+ depends = ros-melodic-rqt-robot-steering
+ depends = ros-melodic-gazebo-ros
+ depends = ros-melodic-xacro
+ depends = ros-melodic-rviz
+ depends = ros-melodic-robot-state-publisher
+ source = ros-melodic-urdf-sim-tutorial-0.4.0-0.tar.gz::https://github.com/ros-gbp/urdf_sim_tutorial-release/archive/release/melodic/urdf_sim_tutorial/0.4.0-0.tar.gz
+ sha256sums = 520f94f7fe52250069283fc7bdd40b734e9153bdcc11b76309fe9522972d8f77
+
+pkgname = ros-melodic-urdf-sim-tutorial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fd5d5a68c73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The urdf_sim_tutorial package."
+url='http://www.ros.org/'
+
+pkgname='ros-melodic-urdf-sim-tutorial'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-position-controllers
+ ros-melodic-controller-manager
+ ros-melodic-joint-state-controller
+ ros-melodic-diff-drive-controller
+ ros-melodic-urdf-tutorial
+ ros-melodic-gazebo-ros-control
+ ros-melodic-rqt-robot-steering
+ ros-melodic-gazebo-ros
+ ros-melodic-xacro
+ ros-melodic-rviz
+ ros-melodic-robot-state-publisher)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/urdf_sim_tutorial/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/urdf_sim_tutorial-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="urdf_sim_tutorial-release-release-melodic-urdf_sim_tutorial-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/urdf_sim_tutorial-release/archive/release/melodic/urdf_sim_tutorial/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('520f94f7fe52250069283fc7bdd40b734e9153bdcc11b76309fe9522972d8f77')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}