summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--include_QSet.patch11
3 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a7297fa33bf..ebd1014a4cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-rqt-image-view
pkgdesc = ROS - rqt_image_view provides a GUI plugin for displaying images using image_transport.
pkgver = 0.4.13
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/rqt_image_view
arch = any
license = BSD
@@ -22,7 +22,9 @@ pkgbase = ros-melodic-rqt-image-view
depends = ros-melodic-sensor-msgs
depends = ros-melodic-image-transport
source = ros-melodic-rqt-image-view-0.4.13.tar.gz::https://github.com/ros-visualization/rqt_image_view/archive/0.4.13.tar.gz
+ source = include_QSet.patch
sha256sums = e24e26dc98404966cc827a4e576a3c7465d82076095d1831eb9da49d3a97c4d5
+ sha256sums = c6a8079a952d8ee9560d190e27f124f53c0e78b4d80ec46bbe06ae36f1de85b7
pkgname = ros-melodic-rqt-image-view
diff --git a/PKGBUILD b/PKGBUILD
index b708589b1fad..b41e2d93daa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,10 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rqt_image_view provides a GUI plugin for displaying images using image_transport."
url='https://wiki.ros.org/rqt_image_view'
pkgname='ros-melodic-rqt-image-view'
pkgver='0.4.13'
-_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -41,8 +38,15 @@ depends=(
)
_dir="rqt_image_view-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_image_view/archive/${pkgver}.tar.gz")
-sha256sums=('e24e26dc98404966cc827a4e576a3c7465d82076095d1831eb9da49d3a97c4d5')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/rqt_image_view/archive/${pkgver}.tar.gz"
+ "include_QSet.patch")
+sha256sums=('e24e26dc98404966cc827a4e576a3c7465d82076095d1831eb9da49d3a97c4d5'
+ 'c6a8079a952d8ee9560d190e27f124f53c0e78b4d80ec46bbe06ae36f1de85b7')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ patch --forward --strip=1 --input="${srcdir}/include_QSet.patch"
+}
build() {
# Use ROS environment variables.
@@ -62,9 +66,6 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}
diff --git a/include_QSet.patch b/include_QSet.patch
new file mode 100644
index 000000000000..fe330db4e20c
--- /dev/null
+++ b/include_QSet.patch
@@ -0,0 +1,11 @@
+diff '--color=auto' --unified --recursive --text rqt_image_view-0.4.13/include/rqt_image_view/image_view.h rqt_image_view-0.4.13.new/include/rqt_image_view/image_view.h
+--- rqt_image_view-0.4.13/include/rqt_image_view/image_view.h 2018-05-03 00:27:26.000000000 +0200
++++ rqt_image_view-0.4.13/include/rqt_image_view/image_view.h 2020-01-09 07:57:04.907081398 +0100
+@@ -51,6 +51,7 @@
+ #include <QString>
+ #include <QSize>
+ #include <QWidget>
++#include <QSet>
+
+ #include <vector>
+