summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD31
2 files changed, 7 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 244f261034e0..e0c7bd4b0308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros2-arch-deps
pkgdesc = [Meta-PKG] Dependencies for building ROS2 on Arch
- pkgver = 0.21
+ pkgver = 0.22
pkgrel = 1
url = https://docs.ros.org/
arch = any
@@ -26,11 +26,9 @@ pkgbase = ros2-arch-deps
depends = python-argcomplete
depends = python-build
depends = python-cryptography
- depends = python-empy
depends = python-installer
depends = python-lark-parser
depends = python-netifaces
- depends = python-nose
depends = python-notify2
depends = python-numpy
depends = python-pyqt5
@@ -48,31 +46,10 @@ pkgbase = ros2-arch-deps
depends = tinyxml2
depends = vtk
depends = wget
- depends = python-catkin_pkg
- depends = python-colcon-argcomplete
- depends = python-colcon-bash
+ depends = python-bloom
depends = python-colcon-cd
- depends = python-colcon-cmake
depends = python-colcon-common-extensions
- depends = python-colcon-core
- depends = python-colcon-defaults
- depends = python-colcon-devtools
- depends = python-colcon-library-path
- depends = python-colcon-metadata
- depends = python-colcon-notification
- depends = python-colcon-output
- depends = python-colcon-package-information
- depends = python-colcon-package-selection
- depends = python-colcon-parallel-executor
- depends = python-colcon-powershell
- depends = python-colcon-python-setup-py
- depends = python-colcon-recursive-crawl
- depends = python-colcon-ros
- depends = python-colcon-test-result
- depends = python-colcon-zsh
- depends = python-rosdep
- depends = python-rosdistro
- depends = python-rospkg
+ depends = python-rosinstall-generator
depends = python-vcstool
optdepends = ogre-legacy: backwards-compatible Ogre engine
optdepends = python-matplotlib: for plotting in rqt
diff --git a/PKGBUILD b/PKGBUILD
index 81cfbf0ad99e..046a03713bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: kartikmohta
# Contributor: calvertdw
pkgname=ros2-arch-deps
-pkgver=0.21
+pkgver=0.22
pkgrel=1
pkgdesc="[Meta-PKG] Dependencies for building ROS2 on Arch"
url="https://docs.ros.org/"
@@ -33,11 +33,9 @@ depends=(
'python-argcomplete'
'python-build'
'python-cryptography'
- 'python-empy'
'python-installer'
'python-lark-parser'
'python-netifaces'
- 'python-nose'
'python-notify2'
'python-numpy'
'python-pyqt5'
@@ -56,31 +54,10 @@ depends=(
'vtk'
'wget'
# AUR
- 'python-catkin_pkg'
- 'python-colcon-argcomplete'
- 'python-colcon-bash'
+ 'python-bloom'
'python-colcon-cd'
- 'python-colcon-cmake'
- 'python-colcon-common-extensions'
- 'python-colcon-core'
- 'python-colcon-defaults'
- 'python-colcon-devtools'
- 'python-colcon-library-path'
- 'python-colcon-metadata'
- 'python-colcon-notification'
- 'python-colcon-output'
- 'python-colcon-package-information'
- 'python-colcon-package-selection'
- 'python-colcon-parallel-executor'
- 'python-colcon-powershell'
- 'python-colcon-python-setup-py'
- 'python-colcon-recursive-crawl'
- 'python-colcon-ros'
- 'python-colcon-test-result'
- 'python-colcon-zsh'
- 'python-rosdep'
- 'python-rosdistro'
- 'python-rospkg'
+ 'python-colcon-common-extensions' # metapackage that covers most colcon deps
+ 'python-rosinstall-generator'
'python-vcstool'
)