summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..826c3611fdd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ros2-humble-cv-bridge
+ pkgdesc = This contains CvBridge, which converts between ROS Image messages and OpenCV images.
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = https://index.ros.org/p/cv_bridge/
+ arch = any
+ makedepends = boost
+ depends = ros2-humble
+ depends = opencv
+ depends = python-numpy
+ depends = python-opencv
+ source = https://github.com/ros-perception/vision_opencv/archive/refs/tags/3.2.1.tar.gz
+ sha256sums = bf8a18770ffe3335e9bf96cb89be886a846be10382e67c2dc93cd4e387b2c3f9
+
+pkgname = ros2-humble-cv-bridge
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58f8027a7b34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=cv_bridge
+pkgname=ros2-humble-cv-bridge
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="This contains CvBridge, which converts between ROS Image messages and OpenCV images."
+url="https://index.ros.org/p/cv_bridge/"
+arch=('any')
+makedepends=(
+ 'boost'
+)
+depends=(
+ 'ros2-humble'
+ 'opencv'
+ 'python-numpy'
+ 'python-opencv'
+)
+source=("https://github.com/ros-perception/vision_opencv/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('bf8a18770ffe3335e9bf96cb89be886a846be10382e67c2dc93cd4e387b2c3f9')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S $_pkgname-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}