summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c44b2afa28ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = roundcubemail-plugin-identity-smtp-git
+ pkgdesc = Roundcube plugin to setup different SMTP settings per identity
+ pkgver = r64.b14e295
+ pkgrel = 1
+ url = https://github.com/deflomu/Roundcube-SMTP-per-Identity-Plugin
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = roundcubemail
+ source = roundcubemail-plugin-identity-smtp-git::git+https://github.com/deflomu/Roundcube-SMTP-per-Identity-Plugin.git
+ sha256sums = SKIP
+
+pkgname = roundcubemail-plugin-identity-smtp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c35cc358da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Bart De Vries <bart at mogwai dot be>
+
+pkgname=roundcubemail-plugin-identity-smtp-git
+pkgver=r64.b14e295
+pkgrel=1
+pkgdesc='Roundcube plugin to setup different SMTP settings per identity '
+arch=('any')
+url='https://github.com/deflomu/Roundcube-SMTP-per-Identity-Plugin'
+license=('MIT')
+makedepends=("git")
+depends=('roundcubemail')
+source=("${pkgname}::git+https://github.com/deflomu/Roundcube-SMTP-per-Identity-Plugin.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ _instdir="${pkgdir}"/usr/share/webapps/roundcubemail/plugins/identity_smtp
+ install -dm755 "${_instdir}"/localization
+ cd "${srcdir}/${pkgname}"
+ install -m644 localization/* "${_instdir}"/localization
+ install -m644 composer.json "${_instdir}"
+ install -m644 crowdin.yaml "${_instdir}"
+ install -m644 identity_smtp.js "${_instdir}"
+ install -m644 identity_smtp.php "${_instdir}"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+