summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD47
3 files changed, 65 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a20ed20df54e..45bbffa959bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,40 @@
pkgbase = rpcs3-bin
pkgdesc = Open-source Sony PlayStation 3 Emulator
- pkgver = 0.0.9
+ pkgver = 0.0.32
pkgrel = 1
url = https://rpcs3.net/
arch = x86_64
license = GPL2
makedepends = p7zip
- depends = openal
- depends = qt5-declarative
+ depends = alsa-lib
depends = glew
- depends = vulkan-icd-loader
- depends = hicolor-icon-theme
+ depends = glu
+ depends = libevdev
+ depends = libgl
+ depends = libice
+ depends = libpng
depends = libpulse
+ depends = libsm
+ depends = libx11
+ depends = libxext
depends = ncurses5-compat-libs
+ depends = openal
+ depends = qt6-base
+ depends = qt6-declarative
+ depends = qt6-multimedia
+ depends = qt6-svg
+ depends = sdl2
+ depends = vulkan-icd-loader
+ depends = zlib
+ depends = curl
+ depends = wolfssl
+ depends = flatbuffers
+ depends = pugixml
provides = rpcs3
conflicts = rpcs3
replaces = rpcs3
options = !strip
- source = https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-ffd5a9e91c9d1ee3ec5738da58204e501b3ac132/rpcs3-v0.0.9-9791-ffd5a9e9_linux64.AppImage
- sha256sums = c7360d46eae43e2f35e10ad940baa64c5d6e57e9a7ad942a726d6ac04aa1302e
+ source = https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-f1ef3bdcd7e2b22ecce67705d931de6b43fb9a20/rpcs3-v0.0.32-16396-f1ef3bdc_linux64.AppImage
+ sha256sums = 06aa19f626509d5b90aa3d8365548ee7e1f7fa144931c465c7aa5596391d8ca1
pkgname = rpcs3-bin
-
diff --git a/.gitignore b/.gitignore
index 90746e4e6aaa..ddb369b9a698 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/pkg
-/*.pkg.tar.xz
+/*.pkg.tar.*
/*.AppImage
/src
diff --git a/PKGBUILD b/PKGBUILD
index dad55d731c55..37c36cd151f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,47 @@
# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=rpcs3-bin
-pkgver=0.0.9
-_pkgbuild='9791-ffd5a9e9'
+pkgver=0.0.32
+_pkgbuild='16396-f1ef3bdc'
pkgrel=1
pkgdesc='Open-source Sony PlayStation 3 Emulator'
arch=('x86_64')
url='https://rpcs3.net/'
license=('GPL2')
-depends=(openal qt5-declarative glew vulkan-icd-loader hicolor-icon-theme libpulse ncurses5-compat-libs)
+depends=(
+ alsa-lib
+ glew
+ glu
+ libevdev
+ libgl
+ libice
+ libpng
+ libpulse
+ libsm
+ libx11
+ libxext
+ ncurses5-compat-libs
+ openal
+ qt6-base
+ qt6-declarative
+ qt6-multimedia
+ qt6-svg
+ sdl2
+ vulkan-icd-loader
+ zlib
+ curl
+ wolfssl
+ flatbuffers
+ pugixml
+)
makedepends=('p7zip')
options=('!strip')
replaces=('rpcs3')
provides=('rpcs3')
conflicts=('rpcs3')
-# curl --silent --dump-header - https://github.com/RPCS3/rpcs3-binaries-linux/releases/latest | grep -i '^location: '
-_latest_release="https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-ffd5a9e91c9d1ee3ec5738da58204e501b3ac132"
+# curl --silent --dump-header - https://github.com/RPCS3/rpcs3-binaries-linux/releases/latest | grep -i '^location: ' | sed 's#/tag/#/download/#'
+_latest_release="https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-f1ef3bdcd7e2b22ecce67705d931de6b43fb9a20"
source=("${_latest_release}/rpcs3-v$pkgver-${_pkgbuild}_linux64.AppImage")
-sha256sums=('c7360d46eae43e2f35e10ad940baa64c5d6e57e9a7ad942a726d6ac04aa1302e')
+sha256sums=('06aa19f626509d5b90aa3d8365548ee7e1f7fa144931c465c7aa5596391d8ca1')
prepare()
{
@@ -33,7 +58,7 @@ package()
install -D -m644 'usr/share/applications/rpcs3.desktop' "$pkgdir/usr/share/applications/rpcs3.desktop"
install -D -m644 'usr/share/icons/hicolor/48x48/apps/rpcs3.png' "$pkgdir/usr/share/icons/hicolor/48x48/apps/rpcs3.png"
install -D -m644 'usr/share/icons/hicolor/scalable/apps/rpcs3.svg' "$pkgdir/usr/share/icons/hicolor/scalable/apps/rpcs3.svg"
- install -D -m644 'usr/share/metainfo/rpcs3.appdata.xml' "$pkgdir/usr/share/memetainfo/rpcs3.appdata.xml"
+ install -D -m644 'usr/share/metainfo/rpcs3.metainfo.xml' "$pkgdir/usr/share/memetainfo/rpcs3.metainfo.xml"
install -D -m644 'usr/share/rpcs3/Icons/ui/circle.png' "$pkgdir/usr/share/rpcs3/Icons/ui/circle.png"
install -D -m644 'usr/share/rpcs3/Icons/ui/cross.png' "$pkgdir/usr/share/rpcs3/Icons/ui/cross.png"
install -D -m644 'usr/share/rpcs3/Icons/ui/dpad_down.png' "$pkgdir/usr/share/rpcs3/Icons/ui/dpad_down.png"
@@ -58,8 +83,16 @@ package()
install -D -m644 'usr/share/rpcs3/GuiConfigs/Classic (Bright).qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Classic (Bright).qss"
install -D -m644 'usr/share/rpcs3/GuiConfigs/Darker Style by TheMitoSan.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Darker Style by TheMitoSan.qss"
install -D -m644 'usr/share/rpcs3/GuiConfigs/Envy.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Envy.qss"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/kot-bg.jpg' "$pkgdir/usr/share/rpcs3/GuiConfigs/kot-bg.jpg"
install -D -m644 'usr/share/rpcs3/GuiConfigs/Kuroi (Dark) by Ani.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Kuroi (Dark) by Ani.qss"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_blue.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_blue.png"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_down_blue.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_down_blue.png"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_down_green.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_down_green.png"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_down_white.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_down_white.png"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_green.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_green.png"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/list_arrow_white.png' "$pkgdir/usr/share/rpcs3/GuiConfigs/list_arrow_white.png"
install -D -m644 'usr/share/rpcs3/GuiConfigs/ModernBlue Theme by TheMitoSan.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/ModernBlue Theme by TheMitoSan.qss"
+ install -D -m644 'usr/share/rpcs3/GuiConfigs/Nekotekina by GooseWing.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Nekotekina by GooseWing.qss"
install -D -m644 'usr/share/rpcs3/GuiConfigs/Skyline (Nightfall).qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Skyline (Nightfall).qss"
install -D -m644 'usr/share/rpcs3/GuiConfigs/Skyline.qss' "$pkgdir/usr/share/rpcs3/GuiConfigs/Skyline.qss"
install -D -m644 'usr/share/rpcs3/GuiConfigs/YoRHa-background.jpg' "$pkgdir/usr/share/rpcs3/GuiConfigs/YoRHa-background.jpg"