summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98b4ec9088f7..f8f163b499a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Sep 1 15:47:32 UTC 2016
+# Sat Oct 1 23:54:02 UTC 2016
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
- pkgver = 4.3.0
- pkgrel = 2
+ pkgver = 4.4.0
+ pkgrel = 1
url = http://rr-project.org/
arch = i686
arch = x86_64
@@ -13,8 +13,10 @@ pkgbase = rr
makedepends = gdb
depends = python2-pexpect
depends = gdb
- source = https://github.com/mozilla/rr/archive/4.3.0.tar.gz
- sha1sums = abaf0e13d0e1c80b30846507c7af574484b819e0
+ source = https://github.com/mozilla/rr/archive/4.4.0.tar.gz
+ source = https://github.com/mozilla/rr/commit/b17311c9f7720512f3a25e820c212d09d5799bcd.patch
+ sha1sums = 3807fb7df4de049ca2dd65d1718fc8034c84bee8
+ sha1sums = d453f07e8bee6be2e44b19b079ec030ba5fff968
pkgname = rr
diff --git a/PKGBUILD b/PKGBUILD
index 2cf733c24ace..c2933fdae7ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Previous maintainer: Joel Teichroeb <joel@teichroeb.net>
pkgname=rr
-pkgver=4.3.0
-pkgrel=2
+pkgver=4.4.0
+pkgrel=1
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -11,12 +11,17 @@ license=('custom')
depends=('python2-pexpect' 'gdb')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
-source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz)
-sha1sums=('abaf0e13d0e1c80b30846507c7af574484b819e0')
+source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
+ https://github.com/mozilla/rr/commit/b17311c9f7720512f3a25e820c212d09d5799bcd.patch)
+sha1sums=('3807fb7df4de049ca2dd65d1718fc8034c84bee8'
+ 'd453f07e8bee6be2e44b19b079ec030ba5fff968')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
+
+ # Make ptrace test work if compiled with PIC
+ patch -p1 -i ../b17311c9f7720512f3a25e820c212d09d5799bcd.patch
}
build() {