summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9643338377b4..8a6834dfbd81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Feb 6 17:01:17 UTC 2019
pkgbase = rsound
pkgdesc = Simple solution for streaming PCM data from client to server in real time.
pkgver = 1.1
- pkgrel = 4
+ pkgrel = 5
url = http://github.com/Themaister/RSound
- arch = i686
arch = x86_64
license = GPL
- makedepends = libao
- makedepends = portaudio
- makedepends = openal
- makedepends = alsa-lib
- makedepends = pulseaudio
- makedepends = jack
depends = libao
- depends = portaudio
depends = openal
depends = libpulse
- optdepends = alsa-lib
- optdepends = pulseaudio
- optdepends = jack
+ depends = portaudio
+ depends = jack2
+ depends = libsamplerate
source = https://github.com/Themaister/RSound/archive/v1.1.tar.gz
sha256sums = dd4e32467360c5b49603da9f48bb4e69e4da4f60863a576a9df797091820faf3
diff --git a/PKGBUILD b/PKGBUILD
index 04326782f4c4..072997a45338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,31 @@
pkgname=rsound
pkgver=1.1
-pkgrel=4
+pkgrel=5
pkgdesc='Simple solution for streaming PCM data from client to server in real time.'
url='http://github.com/Themaister/RSound'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
-depends=('libao' 'portaudio' 'openal' 'libpulse')
-optdepends=('alsa-lib' 'pulseaudio' 'jack')
-makedepends=('libao' 'portaudio' 'openal' 'alsa-lib' 'pulseaudio' 'jack')
+depends=('libao'
+ 'openal'
+ 'libpulse'
+ 'portaudio'
+ 'jack2'
+ 'libsamplerate'
+ )
source=("https://github.com/Themaister/RSound/archive/v${pkgver}.tar.gz")
sha256sums=('dd4e32467360c5b49603da9f48bb4e69e4da4f60863a576a9df797091820faf3')
build() {
cd "RSound-${pkgver}"
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr
+
make
}
package() {
cd "RSound-${pkgver}"
- mkdir -p "${pkgdir}/usr/share/man/man1"
- make DESTDIR="${pkgdir}" install
+ make -j1 DESTDIR="${pkgdir}" install
}