summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bde4ef000a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Aug 5 00:37:02 UTC 2016
+pkgbase = rsound-git
+ pkgdesc = A multi-platform, simple PCM audio server and client.
+ pkgver = 0.6.r699.g5148cde
+ pkgrel = 1
+ url = https://github.com/Themaister/RSound
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ optdepends = alsa-lib
+ optdepends = oss
+ optdepends = libao
+ optdepends = portaudio
+ optdepends = openal
+ optdepends = pulseaudio
+ optdepends = jack
+ provides = rsound
+ conflicts = rsound
+ source = rsound-git::git+https://github.com/Themaister/RSound.git
+ md5sums = SKIP
+
+pkgname = rsound-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa9bc75165a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=rsound-git
+pkgver=0.6.r699.g5148cde
+pkgrel=1
+epoch=
+pkgdesc="A multi-platform, simple PCM audio server and client."
+arch=('i686' 'x86_64')
+url="https://github.com/Themaister/RSound"
+license=('GPLv3')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=('alsa-lib' 'oss' 'libao' 'portaudio' 'openal' 'pulseaudio' 'jack')
+checkdepends=()
+provides=(${pkgname%-*})
+conflicts=(${pkgname%-*})
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/Themaister/RSound.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 DOCUMENTATION $pkgdir/usr/share/doc/${pkgname%-*}/DOCUMENTATION
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+