summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 958fa7602320..18ca8e3aeb6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Tue Oct 11 15:52:38 UTC 2016
+# Sat Nov 10 03:03:31 UTC 2018
pkgbase = rst2ctags
- pkgdesc = A simple script to help create ctags-compatible tag files for the sections within a reStructuredText document
- pkgver = 0.1.5
+ pkgdesc = Generates ctags-compatible output for the sections of a reStructuredText document
+ pkgver = 0.2.2
pkgrel = 1
url = https://github.com/jszakmeister/rst2ctags
arch = any
license = BSD
- depends = python2
- source = rst2ctags-0.1.5.tar.gz::https://codeload.github.com/jszakmeister/rst2ctags/tar.gz/v0.1.5
- sha256sums = 6dc874684e04a81101ff2eda5341354f1b3134503d2d0153c1ee12e0beb6ff84
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/jszakmeister/rst2ctags/archive/v0.2.2/rst2ctags-v0.2.2.tar.gz
+ sha512sums = feba8122592b962692b9cce321375b5807ba4e283404ae0876d2c4e429bef4b88753c7f55f8b483a05536347abefde8d6a6f6e93ef9999e920f02a5ae43d5b50
pkgname = rst2ctags
diff --git a/PKGBUILD b/PKGBUILD
index 6cfa5282476d..b727c5ebfd97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: David Vogt <dave at winged dot ch>
pkgname=rst2ctags
-pkgver=0.1.5
+pkgver=0.2.2
pkgrel=1
-pkgdesc="A simple script to help create ctags-compatible tag files for the sections within a reStructuredText document"
+pkgdesc='Generates ctags-compatible output for the sections of a reStructuredText document'
arch=('any')
-depends=('python2')
-url="https://github.com/jszakmeister/rst2ctags"
+url=https://github.com/jszakmeister/rst2ctags
license=('BSD')
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jszakmeister/$pkgname/tar.gz/v$pkgver)
-sha256sums=('6dc874684e04a81101ff2eda5341354f1b3134503d2d0153c1ee12e0beb6ff84')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha512sums=('feba8122592b962692b9cce321375b5807ba4e283404ae0876d2c4e429bef4b88753c7f55f8b483a05536347abefde8d6a6f6e93ef9999e920f02a5ae43d5b50')
-package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- msg2 'Installing license...'
- install -Dm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
-
- msg2 'Installing documentation...'
- install -Dm 644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
- msg2 'Installing...'
- install -Dm 755 rst2ctags.py "$pkgdir/usr/bin/rst2ctags"
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}