summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--RtAudio.patch11
-rw-r--r--alsa.patch11
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6a9cd983274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = rt_lpc-alsa
+ pkgdesc = real-time LPC analysis + synthesis + visualization: ALSA version
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://soundlab.cs.princeton.edu/software/rt_lpc/
+ arch = i686
+ arch = x86_64
+ groups = multimedia
+ license = GPL
+ depends = alsa-lib
+ depends = glu
+ depends = freeglut
+ depends = libxmu
+ provides = rt_lpc-alsa
+ source = http://soundlab.cs.princeton.edu/software/rt_lpc/files/rt_lpc-1.0.tgz
+ source = RtAudio.patch
+ source = alsa.patch
+ md5sums = 468aa24999dd02d8c8abd84c04e37274
+ md5sums = 8cdab915ec05f8fe8b256305f8803b78
+ md5sums = 1160feb623e80c0405e2b0c42fe967c5
+
+pkgname = rt_lpc-alsa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be9b6c34c232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Corey Mwamba <contact.me@coreymwamba.co.uk>
+pkgname=rt_lpc-alsa
+_pkgname=rt_lpc
+pkgver=1.0
+pkgrel=1
+pkgdesc="real-time LPC analysis + synthesis + visualization: ALSA version"
+arch=('i686' 'x86_64')
+url="http://soundlab.cs.princeton.edu/software/rt_lpc/"
+license=('GPL')
+groups=('multimedia')
+depends=('alsa-lib' 'glu' 'freeglut' 'libxmu')
+provides=('rt_lpc-alsa')
+source=("http://soundlab.cs.princeton.edu/software/$_pkgname/files/$_pkgname-$pkgver.tgz" "RtAudio.patch" "alsa.patch")
+md5sums=('468aa24999dd02d8c8abd84c04e37274'
+ '8cdab915ec05f8fe8b256305f8803b78'
+ '1160feb623e80c0405e2b0c42fe967c5')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver/src"
+ patch -i "$srcdir/RtAudio.patch"
+ patch -i "$srcdir/alsa.patch"
+}
+
+build() {
+ cd "$_pkgname-$pkgver/src"
+ make linux-alsa
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p /usr/bin
+ cd "$srcdir/$_pkgname-$pkgver/src"
+ install -p -D $_pkgname -m 0755 $pkgdir/usr/bin/$pkgname
+}
diff --git a/RtAudio.patch b/RtAudio.patch
new file mode 100644
index 000000000000..0068e9ea6ac8
--- /dev/null
+++ b/RtAudio.patch
@@ -0,0 +1,11 @@
+--- RtAudio.cpp 2004-10-25 09:17:30.000000000 +0100
++++ RtAudio.new.cpp 2015-09-18 10:22:47.281883179 +0100
+@@ -38,7 +38,7 @@
+ /************************************************************************/
+
+ // RtAudio: Version 3.0.1, 22 March 2004
+-
++#include <cstdio>
+ #include "RtAudio.h"
+ #include <iostream>
+
diff --git a/alsa.patch b/alsa.patch
new file mode 100644
index 000000000000..5a37c01dc8b3
--- /dev/null
+++ b/alsa.patch
@@ -0,0 +1,11 @@
+--- makefile.alsa 2004-10-25 09:17:30.000000000 +0100
++++ makefile.new.alsa 2015-09-18 10:21:48.491618159 +0100
+@@ -5,7 +5,7 @@
+ CPP=g++
+ INCLUDES=
+ CFLAGS=-D__LINUX_ALSA__ $(INCLUDES) -O3 -c
+-LIBS=-lasound -L/usr/X11R6/lib -lGL -lGLU -lglut -lX11 -lXi -lXext -lXmu -lm
++LIBS=-lasound -L/usr/X11R6/lib -lGL -lGLU -lglut -lX11 -lXi -lXext -lXmu -lm -lpthread
+
+ rt_lpc: $(OBJS)
+ $(CPP) -o $@ $(OBJS) $(LIBS)