summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD53
-rw-r--r--blacklist-native-rtl8192.conf8
-rw-r--r--dkms.conf6
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2be79aea0f60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = rtl8192cu-fixes-git
+ pkgdesc = This is a repackaging of Realtek's own 8192CU USB WiFi driver for Ubuntu 13.10 and later. This packages fixes the issues with the Dlink 131 wifi usb stick revison B
+ pkgver = r81.756f2ec
+ pkgrel = 1
+ url = https://github.com/pvaret/rtl8192cu-fixes
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = dkms
+ conflicts = 8192cu
+ conflicts = rt8192cu
+ conflicts = dkms-8192cu
+ replaces = rtl8192cu-fixe
+ options = !strip
+ source = rtl8192cu-fixes-git::git+https://github.com/pvaret/rtl8192cu-fixes.git
+ source = dkms.conf
+ source = blacklist-native-rtl8192.conf
+ sha256sums = SKIP
+ sha256sums = a7248049e140aff9f84263f5b520b43086dbf4187270677877d6752d94af6b50
+ sha256sums = 68ade9eaf1018b73cb3a6acd68f42ac3714c654527dc63ea664b9664ea5332ea
+
+pkgname = rtl8192cu-fixes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ad4683f21a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Austcool Walker <0ajwalker@gmail.com>
+
+pkgname=rtl8192cu-fixes-git
+pkgver=r81.756f2ec
+pkgrel=1
+pkgdesc="This is a repackaging of Realtek's own 8192CU USB WiFi driver for Ubuntu 13.10 and later. This packages fixes the issues with the Dlink 131 wifi usb stick revison B"
+arch=('any')
+url="https://github.com/pvaret/rtl8192cu-fixes"
+license=('GPL')
+depends=('dkms')
+makedepends=('git')
+replaces=('rtl8192cu-fixe')
+conflicts=("8192cu" "rt8192cu" "dkms-8192cu")
+options=(!strip)
+source=("${pkgname}::git+https://github.com/pvaret/rtl8192cu-fixes.git"
+ "dkms.conf"
+ "blacklist-native-rtl8192.conf")
+sha256sums=('SKIP'
+ 'a7248049e140aff9f84263f5b520b43086dbf4187270677877d6752d94af6b50'
+ '68ade9eaf1018b73cb3a6acd68f42ac3714c654527dc63ea664b9664ea5332ea')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+
+ _installDir="$pkgdir/usr/src/$pkgname-$pkgver"
+
+ install -dm755 "$_installDir"
+ install -m644 "$srcdir/dkms.conf" "$_installDir"
+ install -dm755 "$pkgdir/etc/modprobe.d"
+ install -m644 "$srcdir/blacklist-native-rtl8192.conf" "$pkgdir/etc/modprobe.d/blacklist-native-rtl8192.conf"
+
+ cd "${srcdir}/${pkgname}/"
+
+ rm -fr .git*
+
+ # Disable power saving
+ sed -i 's/^CONFIG_POWER_SAVING \= y/CONFIG_POWER_SAVING = n/' Makefile
+
+ for d in `find . -type d`
+ do
+ install -dm755 "$_installDir/$d"
+ done
+
+ for f in `find . -type f ! -name 'README.md' ! -name '.gitignore'`
+ do
+ install -m644 "${srcdir}/${pkgname}/$f" "$_installDir/$f"
+ done
+
+}
diff --git a/blacklist-native-rtl8192.conf b/blacklist-native-rtl8192.conf
new file mode 100644
index 000000000000..507744e725aa
--- /dev/null
+++ b/blacklist-native-rtl8192.conf
@@ -0,0 +1,8 @@
+## This file ships with the rtl8192-fixes DKMS module.
+## Keep the native (and currently broken) kernel driver from loading so ours
+## is used instead:
+install rtl8192cu /bin/false
+install rtl8192c_common /bin/false
+install rtlwifi /bin/false
+## There is also a new mainline driver starting with kernel v4.4
+install rtl8xxxu /bin/false
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..a13a7395f7e2
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,6 @@
+PACKAGE_NAME="8192cu"
+PACKAGE_VERSION="1.11"
+BUILT_MODULE_NAME="8192cu"
+DEST_MODULE_LOCATION="/kernel/drivers/net/wireless/"
+REMAKE_INITRD="yes"
+AUTOINSTALL="yes"