summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--void_cast.patch13
3 files changed, 2 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee3e7e370673..5b339cbbf921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,6 @@ pkgbase = rtl8723au_bt-dkms
conflicts = rtl8723au_bt
options = !strip
source = rtl8723au_bt::git+https://github.com/lwfinger/rtl8723au_bt.git
- source = void_cast.patch
- sha256sums = SKIP
sha256sums = SKIP
pkgname = rtl8723au_bt-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 13796c7cf5ff..1480867a3709 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,12 @@ depends=('dkms')
conflicts=("${_pkgname}")
makedepends=('git')
options=(!strip)
-source=("$_pkgname::git+https://github.com/lwfinger/rtl8723au_bt.git"
- "void_cast.patch")
-sha256sums=('SKIP' 'SKIP')
+source=("$_pkgname::git+https://github.com/lwfinger/rtl8723au_bt.git")
+sha256sums=('SKIP')
build() {
cd "${srcdir}/${_pkgname}/"
git checkout kernel
- patch -p1 < "${srcdir}/void_cast.patch"
rm -fr .git* readme.txt
}
diff --git a/void_cast.patch b/void_cast.patch
deleted file mode 100644
index a8cdf1a70848..000000000000
--- a/void_cast.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/btusb.c b/btusb.c
-index 2e55325..29479ff 100644
---- a/btusb.c
-+++ b/btusb.c
-@@ -1744,7 +1744,7 @@ static int inject_cmd_complete(struct hci_dev *hdev, __u16 opcode)
- evt->ncmd = 0x01;
- evt->opcode = cpu_to_le16(opcode);
-
-- *skb_put(skb, 1) = 0x00;
-+ *(unsigned char*)skb_put(skb, 1) = 0x00;
-
- bt_cb(skb)->pkt_type = HCI_EVENT_PKT;
-