summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--arm.patch4
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 355c4c66916b..8b33be7219a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,8 +3,12 @@ pkgbase = rtl8814au-dkms-git
pkgver = 4.3.21.r34.ga0c4479
pkgrel = 1
url = https://github.com/zebulon2/rtl8814au
- arch = i686
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
makedepends = git
depends = dkms
@@ -12,8 +16,10 @@ pkgbase = rtl8814au-dkms-git
conflicts = rtl8814au
source = git+https://github.com/zebulon2/rtl8814au.git
source = dkms.conf
+ source = arm.patch
sha256sums = SKIP
sha256sums = 36203d04d3ff9e4f117389a24257f608570c418bf4b93fba1b4efd41eb36229a
+ sha256sums = 2911f6c1285277d0507b2ad7a09c20edd682476be67502db63f63663cac97efb
pkgname = rtl8814au-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index c8dbc5c28cf5..bb2ed1f6fe88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: zebulon <zeb (at)zebulon(dot)org(dot)uk>
# Contributor: NovaMoon <novamoon1 (at)gmail(dot)com>
+# Contributor: Erikas Rudinskas <erikmnkl (at)gmail(dot)com>
pkgname=rtl8814au-dkms-git
_pkgbase=rtl8814au
pkgver=4.3.21.r34.ga0c4479
pkgrel=1
pkgdesc="RTL8814AU and RTL8813AU chipset driver with firmware v4.3.21"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/zebulon2/rtl8814au"
license=('GPL2')
depends=('dkms' 'bc')
makedepends=('git')
conflicts=("${_pkgbase}")
source=("git+https://github.com/zebulon2/rtl8814au.git"
- 'dkms.conf')
+ 'dkms.conf'
+ 'arm.patch')
sha256sums=('SKIP'
- '36203d04d3ff9e4f117389a24257f608570c418bf4b93fba1b4efd41eb36229a')
+ '36203d04d3ff9e4f117389a24257f608570c418bf4b93fba1b4efd41eb36229a'
+ '2911f6c1285277d0507b2ad7a09c20edd682476be67502db63f63663cac97efb')
pkgver() {
cd ${srcdir}/rtl8814au
@@ -23,7 +26,11 @@ pkgver() {
}
package() {
- cd ${srcdir}/rtl8814au
+ if [ "$CARCH" = "arm" ] || [ "$CARCH" = "armv6h" ] || [ "$CARCH" = "armv7h" ] || [ "$CARCH" = "aarch64" ]; then
+ msg2 "Applying patch for ARM architecture..."
+ patch ${srcdir}/rtl8814au/Makefile -i ${srcdir}/arm.patch
+ fi
+ cd ${srcdir}/rtl8814au
mkdir -p ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp -pr * ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp ${srcdir}/dkms.conf ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
diff --git a/arm.patch b/arm.patch
new file mode 100644
index 000000000000..c5778591fecd
--- /dev/null
+++ b/arm.patch
@@ -0,0 +1,4 @@
+921c921
+< ARCH ?= $(SUBARCH)
+---
+> ARCH := arm