summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 734189f8e717..53215044ae5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Jun 14 05:06:32 UTC 2017
pkgbase = rtmpdump-git
pkgdesc = A tool to download rtmp and rtmpe streams
pkgver = 0.512.fa8646d
@@ -8,7 +10,7 @@ pkgbase = rtmpdump-git
license = GPL2
license = LGPL2.1
makedepends = git
- depends = openssl
+ depends = gnutls
provides = rtmpdump
conflicts = rtmpdump
source = git+git://git.ffmpeg.org/rtmpdump
diff --git a/PKGBUILD b/PKGBUILD
index 7e1cb5eeb49d..72d60076dfc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="A tool to download rtmp and rtmpe streams"
url="http://rtmpdump.mplayerhq.hu/"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
-depends=('openssl')
+depends=('gnutls')
makedepends=('git')
provides=('rtmpdump')
conflicts=('rtmpdump')
@@ -23,6 +23,7 @@ pkgver() {
build() {
cd "$srcdir/rtmpdump"
+ sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
make OPT="$CFLAGS" XLDFLAGS="$LDFLAGS"
}