summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
-rw-r--r--ps-fix-double-slash-319_all.patch7
-rw-r--r--ps-handle-sighup-578_all.patch6
4 files changed, 35 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d054a430333..51dfd9c1e349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 17 18:19:43 UTC 2017
+# Sat Mar 18 00:25:09 UTC 2017
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
- pkgver = 1.0.r29.gad0cb71
+ pkgver = 1.0.r32.g832b03d
pkgrel = 1
url = https://github.com/pyroscope/rtorrent-ps
arch = any
@@ -23,7 +23,9 @@ pkgbase = rtorrent-ps
conflicts = rtorrent-vi-color
source = https://github.com/rakshasa/rtorrent/archive/0.9.6.tar.gz
source = command_pyroscope.cc
+ source = ps-fix-double-slash-319_all.patch
source = ps-fix-sort-started-stopped-views_all.patch
+ source = ps-handle-sighup-578_all.patch
source = ps-info-pane-xb-sizes_all.patch
source = ps-item-stats-human-sizes_all.patch
source = ps-ssl_verify_host_all.patch
@@ -35,7 +37,9 @@ pkgbase = rtorrent-ps
source = ui_pyroscope.patch
md5sums = b8b4009f95f8543244ae1d23b1810d7c
md5sums = 01e9e7dddf9ebcdca81d88dfdd43b4dc
+ md5sums = 22fae392c6e281dc438b39a5019e7e1b
md5sums = 3fd739c0d5a9442f0cdec9ed5a720eaa
+ md5sums = 2137e16f8b881170fb92fb7a6c276193
md5sums = f1539d70c74e5c74d8a15d51675aa26c
md5sums = 2d34e8c86c1c6ed1354b55ca21819886
md5sums = cef14e9011d4b4af92536b02f8b611c2
diff --git a/PKGBUILD b/PKGBUILD
index 4312eb69f836..732ad7ed1260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rtorrent
pkgname=rtorrent-ps
_pkgver=0.9.6
-pkgver=1.0.r29.gad0cb71
+pkgver=1.0.r32.g832b03d
pkgrel=1
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
@@ -13,20 +13,24 @@ depends=('cppunit' 'curl>=7.15.4' 'libtorrent-ps>=1.0' 'ncurses' 'xmlrpc-c')
provides=('rtorrent')
conflicts=('rtorrent' 'rtorrent-cdl' 'rtorrent-color' 'rtorrent-git' 'rtorrent-ipv6' 'rtorrent-ps-git' 'rtorrent-pyro-git' 'rtorrent-vi-color')
source=("https://github.com/rakshasa/$_pkgname/archive/$_pkgver.tar.gz"
- "command_pyroscope.cc"
- "ps-fix-sort-started-stopped-views_all.patch"
- "ps-info-pane-xb-sizes_all.patch"
- "ps-item-stats-human-sizes_all.patch"
- "ps-ssl_verify_host_all.patch"
- "ps-throttle-steps_all.patch"
- "ps-ui_pyroscope_all.patch"
- "pyroscope.patch"
- "ui_pyroscope.cc"
- "ui_pyroscope.h"
- "ui_pyroscope.patch")
+ 'command_pyroscope.cc'
+ 'ps-fix-double-slash-319_all.patch'
+ 'ps-fix-sort-started-stopped-views_all.patch'
+ 'ps-handle-sighup-578_all.patch'
+ 'ps-info-pane-xb-sizes_all.patch'
+ 'ps-item-stats-human-sizes_all.patch'
+ 'ps-ssl_verify_host_all.patch'
+ 'ps-throttle-steps_all.patch'
+ 'ps-ui_pyroscope_all.patch'
+ 'pyroscope.patch'
+ 'ui_pyroscope.cc'
+ 'ui_pyroscope.h'
+ 'ui_pyroscope.patch')
md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'01e9e7dddf9ebcdca81d88dfdd43b4dc'
+ '22fae392c6e281dc438b39a5019e7e1b'
'3fd739c0d5a9442f0cdec9ed5a720eaa'
+ '2137e16f8b881170fb92fb7a6c276193'
'f1539d70c74e5c74d8a15d51675aa26c'
'2d34e8c86c1c6ed1354b55ca21819886'
'cef14e9011d4b4af92536b02f8b611c2'
diff --git a/ps-fix-double-slash-319_all.patch b/ps-fix-double-slash-319_all.patch
new file mode 100644
index 000000000000..17f3e2bc182d
--- /dev/null
+++ b/ps-fix-double-slash-319_all.patch
@@ -0,0 +1,7 @@
+--- a/src/core/manager.cc
++++ b/src/core/manager.cc
+@@ -418,3 +418,3 @@ path_expand(std::vector<std::string>* paths, const std::string& pattern) {
+
+- std::transform(itr->begin(), itr->end(), std::back_inserter(nextCache), rak::bind1st(std::ptr_fun(&path_expand_transform), itr->path() + "/"));
++ std::transform(itr->begin(), itr->end(), std::back_inserter(nextCache), rak::bind1st(std::ptr_fun(&path_expand_transform), itr->path() + (itr->path() == "/" ? "" : "/")));
+ }
diff --git a/ps-handle-sighup-578_all.patch b/ps-handle-sighup-578_all.patch
new file mode 100644
index 000000000000..59a686082b41
--- /dev/null
+++ b/ps-handle-sighup-578_all.patch
@@ -0,0 +1,6 @@
+--- a/src/main.cc
++++ b/src/main.cc
+@@ -199,2 +199,3 @@ main(int argc, char** argv) {
+ SignalHandler::set_handler(SIGINT, std::tr1::bind(&Control::receive_normal_shutdown, control));
++ SignalHandler::set_handler(SIGHUP, std::tr1::bind(&Control::receive_normal_shutdown, control));
+ SignalHandler::set_handler(SIGTERM, std::tr1::bind(&Control::receive_quick_shutdown, control));