summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--ps-fix-sort-started-stopped-views_all.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b11adfa0bb..2f7415b13ca8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 11 22:41:04 UTC 2017
+# Mon Mar 13 00:30:19 UTC 2017
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
pkgver = 0.9.6
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/pyroscope/rtorrent-ps
arch = any
license = GPL
@@ -23,6 +23,7 @@ pkgbase = rtorrent-ps
conflicts = rtorrent-vi-color
source = https://github.com/rakshasa/rtorrent/archive/0.9.6.tar.gz
source = command_pyroscope.cc
+ source = ps-fix-sort-started-stopped-views_all.patch
source = ps-info-pane-xb-sizes_all.patch
source = ps-item-stats-human-sizes_all.patch
source = ps-ssl_verify_host_all.patch
@@ -34,6 +35,7 @@ pkgbase = rtorrent-ps
source = ui_pyroscope.patch
md5sums = b8b4009f95f8543244ae1d23b1810d7c
md5sums = d44e605a784ec45b0bfafce3676842c4
+ md5sums = 3fd739c0d5a9442f0cdec9ed5a720eaa
md5sums = f1539d70c74e5c74d8a15d51675aa26c
md5sums = 2d34e8c86c1c6ed1354b55ca21819886
md5sums = cef14e9011d4b4af92536b02f8b611c2
diff --git a/PKGBUILD b/PKGBUILD
index 8ea4578dac10..536093a9b551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rtorrent
pkgname=rtorrent-ps
pkgver=0.9.6
-pkgrel=3
+pkgrel=4
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
license=('GPL')
@@ -13,6 +13,7 @@ provides=('rtorrent')
conflicts=('rtorrent' 'rtorrent-cdl' 'rtorrent-color' 'rtorrent-git' 'rtorrent-ipv6' 'rtorrent-ps-git' 'rtorrent-pyro-git' 'rtorrent-vi-color')
source=("https://github.com/rakshasa/$_pkgname/archive/$pkgver.tar.gz"
"command_pyroscope.cc"
+ "ps-fix-sort-started-stopped-views_all.patch"
"ps-info-pane-xb-sizes_all.patch"
"ps-item-stats-human-sizes_all.patch"
"ps-ssl_verify_host_all.patch"
@@ -24,6 +25,7 @@ source=("https://github.com/rakshasa/$_pkgname/archive/$pkgver.tar.gz"
"ui_pyroscope.patch")
md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'd44e605a784ec45b0bfafce3676842c4'
+ '3fd739c0d5a9442f0cdec9ed5a720eaa'
'f1539d70c74e5c74d8a15d51675aa26c'
'2d34e8c86c1c6ed1354b55ca21819886'
'cef14e9011d4b4af92536b02f8b611c2'
diff --git a/ps-fix-sort-started-stopped-views_all.patch b/ps-fix-sort-started-stopped-views_all.patch
new file mode 100644
index 000000000000..a7a7924138d2
--- /dev/null
+++ b/ps-fix-sort-started-stopped-views_all.patch
@@ -0,0 +1,13 @@
+--- rel-0.9.6/src/core/view.cc 2015-09-03 20:03:30.000000000 +0100
++++ rtorrent-0.9.6/src/core/view.cc 2016-07-06 17:13:47.180101179 +0100
+@@ -257,6 +257,10 @@ View::sort() {
+
+ void
+ View::filter() {
++ // Do NOT allow filter STARTED and STOPPED views: they are special
++ if (m_name == "started" || m_name == "stopped")
++ return;
++
+ // Parition the list in two steps so we know which elements changed.
+ iterator splitVisible = std::stable_partition(begin_visible(), end_visible(), view_downloads_filter(m_filter));
+ iterator splitFiltered = std::stable_partition(begin_filtered(), end_filtered(), view_downloads_filter(m_filter));