summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--ps-max_scgi_size_all.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63ebc24e9020..79982bb943f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
- pkgver = 1.1.r42.g37c9d4b
+ pkgver = 1.1.r43.g8be91ab
pkgrel = 1
url = https://github.com/pyroscope/rtorrent-ps
arch = any
license = GPL
- depends = curl>=7.15.4
- depends = libtorrent-ps>=1.0
+ depends = curl
+ depends = libtorrent-ps
depends = ncurses
depends = xmlrpc-c
provides = rtorrent
@@ -27,6 +27,7 @@ pkgbase = rtorrent-ps
source = ps-issue-515_all.patch
source = ps-item-stats-human-sizes_all.patch
source = ps-log_messages_all.patch
+ source = ps-max_scgi_size_all.patch
source = ps-object_std-map-serialization_all.patch
source = ps-silent-catch_all.patch
source = ps-ssl_verify_host_all.patch
@@ -54,6 +55,7 @@ pkgbase = rtorrent-ps
md5sums = c438a91cd3e58edebf39fce06587641a
md5sums = 2d34e8c86c1c6ed1354b55ca21819886
md5sums = a4f5a4da3397e4b1d71eb59a5e8e0279
+ md5sums = 0cbbbb2c87d046d8a39c3a6da13e7187
md5sums = 0fa551b7cba264bd906e32827d06700c
md5sums = e3f367abe42d28168008f99a9bf0f1d6
md5sums = cef14e9011d4b4af92536b02f8b611c2
diff --git a/PKGBUILD b/PKGBUILD
index ae970f078433..4b3684ae11f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=rtorrent
pkgname=rtorrent-ps
_pkgver=0.9.6
-pkgver=1.1.r42.g37c9d4b
+pkgver=1.1.r43.g8be91ab
pkgrel=1
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
license=('GPL')
arch=('any')
-depends=('curl>=7.15.4' 'libtorrent-ps>=1.0' 'ncurses' 'xmlrpc-c')
+depends=('curl' 'libtorrent-ps' 'ncurses' 'xmlrpc-c')
provides=('rtorrent')
conflicts=('rtorrent')
source=("https://github.com/rakshasa/$_pkgname/archive/v$_pkgver.tar.gz"
@@ -28,6 +28,7 @@ source=("https://github.com/rakshasa/$_pkgname/archive/v$_pkgver.tar.gz"
'ps-issue-515_all.patch'
'ps-item-stats-human-sizes_all.patch'
'ps-log_messages_all.patch'
+ 'ps-max_scgi_size_all.patch'
'ps-object_std-map-serialization_all.patch'
'ps-silent-catch_all.patch'
'ps-ssl_verify_host_all.patch'
@@ -55,6 +56,7 @@ md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'c438a91cd3e58edebf39fce06587641a'
'2d34e8c86c1c6ed1354b55ca21819886'
'a4f5a4da3397e4b1d71eb59a5e8e0279'
+ '0cbbbb2c87d046d8a39c3a6da13e7187'
'0fa551b7cba264bd906e32827d06700c'
'e3f367abe42d28168008f99a9bf0f1d6'
'cef14e9011d4b4af92536b02f8b611c2'
diff --git a/ps-max_scgi_size_all.patch b/ps-max_scgi_size_all.patch
new file mode 100644
index 000000000000..fd7ffae30e19
--- /dev/null
+++ b/ps-max_scgi_size_all.patch
@@ -0,0 +1,13 @@
+diff --git a/src/rpc/scgi_task.h b/src/rpc/scgi_task.h
+index e75e9e1..c36de13 100644
+--- a/src/rpc/scgi_task.h
++++ b/src/rpc/scgi_task.h
+@@ -51,7 +51,7 @@ class SCgiTask : public torrent::Event {
+ public:
+ static const unsigned int default_buffer_size = 2047;
+ static const int max_header_size = 2000;
+- static const int max_content_size = (2 << 20);
++ static const int max_content_size = (2 << 23);
+
+ SCgiTask() { m_fileDesc = -1; }
+