summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af54dfd26b22..4dfbfeddd9a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rua
pkgdesc = AUR helper in Rust providing control, review and jailed/offline build options
pkgver = 0.14.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vn971/rua
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3fa9da556df8..51ceeef26ee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rua
pkgver=0.14.6
-pkgrel=1
+pkgrel=2
pkgdesc='AUR helper in Rust providing control, review and jailed/offline build options'
url='https://github.com/vn971/rua'
source=("https://github.com/vn971/rua/archive/${pkgver}.tar.gz")
@@ -24,9 +24,13 @@ build () {
cd "$srcdir/$pkgname-$pkgver"
mkdir -p target/completions
+ if pacman -T pacman-git > /dev/null; then
+ _features="git"
+ fi
+
RUSTUP_TOOLCHAIN=stable \
COMPLETIONS_DIR=target/completions \
- cargo build --release
+ cargo build --features "${_features:-}" --release
}
package() {