summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f7e1c15ef1..fba039554709 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rua
pkgdesc = convenient jailed AUR helper in rust
pkgver = 0.6.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vn971/rua
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d1a9f46eb706..bbefb6d80d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rua
pkgver=0.6.2
-pkgrel=1
+pkgrel=2
pkgdesc='convenient jailed AUR helper in rust'
url='https://github.com/vn971/rua'
source=("https://github.com/vn971/rua/archive/${pkgver}.tar.gz")
@@ -15,6 +15,14 @@ sha256sums=(b232e7b57f5c10ad77d793272764bc363b2d223dfe7e198d81da173fd46d085d)
build () {
cd "$srcdir/$pkgname-$pkgver"
+ if ! rustc --version; then
+ if command -v rustup; then
+ rustup install stable
+ rustup default stable
+ else
+ echo "Failed to run rustc and rustup. Is default toolchain configured correctly?" 1>&2
+ fi
+ fi
mkdir -p target/completions
COMPLETIONS_DIR=completions cargo build --release
}