summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a7a9f0b70b..af54dfd26b22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rua
pkgdesc = AUR helper in Rust providing control, review and jailed/offline build options
- pkgver = 0.14.5
- pkgrel = 2
+ pkgver = 0.14.6
+ pkgrel = 1
url = https://github.com/vn971/rua
arch = x86_64
arch = i686
@@ -12,8 +12,8 @@ pkgbase = rua
depends = pacman
optdepends = bubblewrap-suid: version of bubblewrap that works on linux-hardened kernel
optdepends = sudo: package installation can be done via sudo, if convenient
- source = https://github.com/vn971/rua/archive/0.14.5.tar.gz
- sha256sums = a5ee258589f515b0ba258169a5f333e8fa7f3ff72e767729e78dc19ae0267afb
+ source = https://github.com/vn971/rua/archive/0.14.6.tar.gz
+ sha256sums = 607f8e0c05887d21d366d5010efabd5b580b531a5d3f3492bb9754b357dac35d
pkgname = rua
diff --git a/PKGBUILD b/PKGBUILD
index 59cebbf8aa09..3fa9da556df8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
pkgname=rua
-pkgver=0.14.5
-pkgrel=2
+pkgver=0.14.6
+pkgrel=1
pkgdesc='AUR helper in Rust providing control, review and jailed/offline build options'
url='https://github.com/vn971/rua'
source=("https://github.com/vn971/rua/archive/${pkgver}.tar.gz")
@@ -18,11 +18,12 @@ optdepends=(
#options+=(!strip) # uncomment if you want readable stack traces
-sha256sums=(a5ee258589f515b0ba258169a5f333e8fa7f3ff72e767729e78dc19ae0267afb)
+sha256sums=(607f8e0c05887d21d366d5010efabd5b580b531a5d3f3492bb9754b357dac35d)
build () {
cd "$srcdir/$pkgname-$pkgver"
mkdir -p target/completions
+
RUSTUP_TOOLCHAIN=stable \
COMPLETIONS_DIR=target/completions \
cargo build --release