summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..683b2c31aff0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-capistrano-maintenance
+ pkgdesc = This gem simply offers the recently removed deploy:web:disable and deploy:web:enable tasks to your Capistrano deployment.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://rubygems.org/gems/capistrano-maintenance
+ arch = any
+ license = Custom
+ depends = ruby
+ depends = rubygems
+ noextract = capistrano-maintenance-0.0.2.gem
+ source = http://rubygems.org/downloads/capistrano-maintenance-0.0.2.gem
+ md5sums = 959dc359a7d0e4eb13fc553aa4227440
+
+pkgname = ruby-capistrano-maintenance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a4a6562eae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
+pkgname=ruby-capistrano-maintenance
+_gemname=${pkgname#ruby-}
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='This gem simply offers the recently removed deploy:web:disable and deploy:web:enable tasks to your Capistrano deployment.'
+arch=('any')
+url='http://rubygems.org/gems/capistrano-maintenance'
+license=('Custom')
+depends=('ruby' 'rubygems')
+source=(http://rubygems.org/downloads/${_gemname}-${pkgver}.gem)
+noextract=(${_gemname}-${pkgver}.gem)
+md5sums=('959dc359a7d0e4eb13fc553aa4227440')
+
+build() {
+ cd "${srcdir}"
+ export HOME=/tmp
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i "${pkgdir}${_gemdir}" ${_gemname}-${pkgver}.gem
+}