summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd849cfe6597
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ruby-instance_storage
+ pkgdesc = Manage class instances with dictionary
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = instance_storage-1.0.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/instance_storage-1.0.0.gem
+ sha1sums = 84fc7da9d362ecf6e806b2eb785fa19d75eff9e9
+
+pkgname = ruby-instance_storage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..320dc3ebc89e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.gem
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cab4d061c63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: 2GMon <2gmon.t@gmail.com>
+
+_gemname=instance_storage
+pkgname=ruby-$_gemname
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Manage class instances with dictionary'
+arch=(any)
+url=''
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('84fc7da9d362ecf6e806b2eb785fa19d75eff9e9')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}