summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..903f4afb30c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-jekyll-watch
+ pkgdesc = Rebuild your Jekyll site when a file changes with the `--watch` switch.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/jekyll/jekyll-watch
+ arch = any
+ license = MIT
+ depends = ruby-listen
+ noextract = jekyll-watch-1.2.1.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/jekyll-watch-1.2.1.gem
+ sha1sums = d61f152af17fd32cb76ffd4192a6f46eaf71e06c
+
+pkgname = ruby-jekyll-watch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..024fac3e4afb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+_gemname=jekyll-watch
+pkgname=ruby-$_gemname
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='Rebuild your Jekyll site when a file changes with the `--watch` switch.'
+arch=(any)
+url='https://github.com/jekyll/jekyll-watch'
+license=(MIT)
+depends=(ruby-listen)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('d61f152af17fd32cb76ffd4192a6f46eaf71e06c')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}