summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf9de574a017
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-pluggaloid
+ pkgdesc = Extensible plugin system
+ pkgver = 1.0.2
+ pkgrel = 1
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-delayer
+ depends = ruby-instance_storage
+ noextract = pluggaloid-1.0.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/pluggaloid-1.0.2.gem
+ sha1sums = dd024ff41cbcadeb16f1a5e0bcca142adda2511a
+
+pkgname = ruby-pluggaloid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..320dc3ebc89e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.gem
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..646c1edd3786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: 2GMon <2gmon.t@gmail.com>
+
+_gemname=pluggaloid
+pkgname=ruby-$_gemname
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Extensible plugin system'
+arch=(any)
+url=''
+license=(MIT)
+depends=(ruby ruby-delayer ruby-instance_storage)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('dd024ff41cbcadeb16f1a5e0bcca142adda2511a')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}