summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af1c18eb0f8d..73bb6556d9fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jun 12 15:05:05 UTC 2016
pkgbase = ruby-typhoeus
pkgdesc = Parallel HTTP library on top of libcurl multi.
- pkgver = 0.7.3
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/typhoeus/typhoeus
arch = any
license = MIT
depends = ruby
- depends = ruby-ethon
- noextract = typhoeus-0.7.3.gem
+ depends = ruby-ethon>=0.9.0
+ noextract = typhoeus-1.0.2.gem
options = !emptydirs
- source = https://rubygems.org/downloads/typhoeus-0.7.3.gem
- sha1sums = 7e1344b42aba92985475c708717cadc031818948
+ source = https://rubygems.org/downloads/typhoeus-1.0.2.gem
+ sha512sums = 0624154c9456f8b1587629f8ad1cfc75a60cf896d7272eecf653ffb35f6769979ac751bc65636d67d3a6339f5a6320398b8ee78ac979f9ba2cbd2d6e44988c0a
pkgname = ruby-typhoeus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 4f894db2cc0b..df31dc6e2577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Generated by gem2arch (https://github.com/anatol/gem2arch)
-# Maintainer: Rhys Davies <rhys@johnguant.com>
+#Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
_gemname=typhoeus
pkgname=ruby-$_gemname
-pkgver=0.7.3
+pkgver=1.0.2
pkgrel=1
pkgdesc='Parallel HTTP library on top of libcurl multi.'
arch=(any)
url='https://github.com/typhoeus/typhoeus'
license=(MIT)
-depends=(ruby ruby-ethon)
+depends=('ruby' 'ruby-ethon>=0.9.0')
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha1sums=('7e1344b42aba92985475c708717cadc031818948')
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"
@@ -21,3 +20,4 @@ package() {
rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+sha512sums=('0624154c9456f8b1587629f8ad1cfc75a60cf896d7272eecf653ffb35f6769979ac751bc65636d67d3a6339f5a6320398b8ee78ac979f9ba2cbd2d6e44988c0a')