summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b495c2ea6d5b..847f9dc2d4b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = run-one
pkgdesc = Run just one instance of a command and its args at a time
pkgver = 1.17
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/run-one
arch = any
license = GPL3
depends = sh
- depends = util-linux
- source = run-one-1.17.tgz::https://bazaar.launchpad.net/~run-one/run-one/trunk/tarball/70
- sha256sums = 2582ec486ad91dacda511967a87fd80eec6bf924867576477c8f5cd93df3f91a
+ source = run-one-1.17.tgz::https://launchpad.net/run-one/trunk/1.17/+download/run-one_1.17.orig.tar.gz
+ sha256sums = b7c9b257b52f29ba0d923a4dfee4edd47332ebeca0200c65f309eb6ae33f701f
pkgname = run-one
-
diff --git a/PKGBUILD b/PKGBUILD
index 4cc06c299298..9627bf2b17c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+
pkgname=run-one
-_bzr=70
pkgver=1.17
-pkgrel=2
-pkgdesc="Run just one instance of a command and its args at a time "
+pkgrel=3
+pkgdesc="Run just one instance of a command and its args at a time"
arch=('any')
url="https://launchpad.net/run-one"
license=('GPL3')
-depends=('sh' 'util-linux')
-source=("$pkgname-$pkgver.tgz::https://bazaar.launchpad.net/~run-one/run-one/trunk/tarball/$_bzr")
+depends=('sh')
+source=("$pkgname-$pkgver.tgz::$url/trunk/$pkgver/+download/${pkgname}_$pkgver.orig.tar.gz")
+sha256sums=('b7c9b257b52f29ba0d923a4dfee4edd47332ebeca0200c65f309eb6ae33f701f')
package() {
- cd "~$pkgname/$pkgname/trunk"
- mkdir -p "$pkgdir/usr/bin/"
- mv run-one keep-one-running run-one-constantly run-one-until-failure run-one-until-success run-this-one "$pkgdir/usr/bin/"
- install -Dm644 run-one.1 "$pkgdir/usr/share/man/man1/run-one.1"
+ cd "$pkgname-$pkgver"
+ install -Dvt "$pkgdir/usr/bin/" \
+ run-one \
+ keep-one-running \
+ run-one-constantly \
+ run-one-until-failure \
+ run-one-until-success \
+ run-this-one
+ install -Dvm644 "$pkgname.1" -t "$pkgdir/usr/share/man/man1/"
}
-
-sha256sums=('2582ec486ad91dacda511967a87fd80eec6bf924867576477c8f5cd93df3f91a')