summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..391ebcf2f479
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = runin
+ pkgdesc = Launch a terminal to run a command, passing on stdin & stdout
+ pkgver = r2.a9636d1
+ pkgrel = 1
+ url = https://github.com/nichobi/runin
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ provides = ronin
+ source = git+https://github.com/nichobi/runin
+ md5sums = SKIP
+
+pkgname = runin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07926670ba57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nicholas Boyd Isacsson <nicholas@isacsson.se>
+
+pkgname=runin
+pkgver=r2.a9636d1
+pkgrel=1
+pkgdesc='Launch a terminal to run a command, passing on stdin & stdout'
+arch=('any')
+url="https://github.com/nichobi/${pkgname}"
+license=('GPL3')
+depends=('bash')
+makedepends=('git')
+provides=('ronin')
+source=(git+$url)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -vDm 755 runin -t "${pkgdir}/usr/bin/"
+}
+