summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a317f57d480b..687f5183298e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rust-analyzer-bin
pkgdesc = An experimental Rust compiler front-end for IDEs. Binary build.
pkgver = 20200127
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rust-analyzer/rust-analyzer
arch = x86_64
license = MIT
@@ -10,7 +10,7 @@ pkgbase = rust-analyzer-bin
conflicts = rust-analyzer
conflicts = rust-analyzer-git
conflicts = rust-analyzer-vscode-git
- source = ra_lsp_server::https://github.com/rust-analyzer/rust-analyzer/releases/download/2020-01-27/ra_lsp_server-linux
+ source = ra_lsp_server-2020-01-27::https://github.com/rust-analyzer/rust-analyzer/releases/download/2020-01-27/ra_lsp_server-linux
md5sums = 7ee3e7ac47fc418c360a0c33a0ffc339
pkgname = rust-analyzer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 97d341aca973..574cc48e0d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=rust-analyzer-bin
pkgver=20200127
_pkgver='2020-01-27'
-pkgrel=1
+pkgrel=2
pkgdesc="An experimental Rust compiler front-end for IDEs. Binary build."
arch=('x86_64')
url="https://github.com/rust-analyzer/rust-analyzer"
license=('MIT' 'Apache')
provides=('rust-analyzer')
conflicts=('rust-analyzer' 'rust-analyzer-git' 'rust-analyzer-vscode-git')
-source=("ra_lsp_server::$url/releases/download/$_pkgver/ra_lsp_server-linux")
+source=("ra_lsp_server-$_pkgver::$url/releases/download/$_pkgver/ra_lsp_server-linux")
md5sums=('7ee3e7ac47fc418c360a0c33a0ffc339')
pkgver() {
@@ -19,5 +19,5 @@ pkgver() {
package() {
cd "$srcdir"
- install -Dm 755 "ra_lsp_server" -t "$pkgdir/usr/bin/"
+ install -Dm 755 "ra_lsp_server-$_pkgver" "$pkgdir/usr/bin/ra_lsp_server"
}