summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c9af914c3ed..85e804fdbc50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rust-analyzer-bin
pkgdesc = An experimental Rust compiler front-end for IDEs. Binary build.
- pkgver = 20200217
- pkgrel = 1
+ pkgver = 20200224
+ pkgrel = 2
url = https://github.com/rust-analyzer/rust-analyzer
arch = x86_64
license = MIT
@@ -10,8 +10,8 @@ pkgbase = rust-analyzer-bin
conflicts = rust-analyzer
conflicts = rust-analyzer-git
conflicts = rust-analyzer-vscode-git
- source = ra_lsp_server-2020-02-17::https://github.com/rust-analyzer/rust-analyzer/releases/download/2020-02-17/ra_lsp_server-linux
- md5sums = 10da24fbd829488d31834ad1b5335a27
+ source = rust-analyzer-2020-02-24::https://github.com/rust-analyzer/rust-analyzer/releases/download/2020-02-24/rust-analyzer-linux
+ md5sums = 0860ce1664a32d988189221a969f926c
pkgname = rust-analyzer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 072ce52680f7..7b30b5dc30b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Sergey A. <murlakatamenka@disroot.org>
pkgname=rust-analyzer-bin
-pkgver=20200217
-_pkgver='2020-02-17'
-pkgrel=1
+pkgver=20200224
+_pkgver='2020-02-24'
+pkgrel=2
pkgdesc="An experimental Rust compiler front-end for IDEs. Binary build."
arch=('x86_64')
url="https://github.com/rust-analyzer/rust-analyzer"
license=('MIT' 'Apache')
provides=('rust-analyzer')
conflicts=('rust-analyzer' 'rust-analyzer-git' 'rust-analyzer-vscode-git')
-source=("ra_lsp_server-$_pkgver::$url/releases/download/$_pkgver/ra_lsp_server-linux")
-md5sums=('10da24fbd829488d31834ad1b5335a27')
+source=("rust-analyzer-$_pkgver::$url/releases/download/$_pkgver/rust-analyzer-linux")
+md5sums=('0860ce1664a32d988189221a969f926c')
pkgver() {
echo ${_pkgver//-}
@@ -19,5 +19,5 @@ pkgver() {
package() {
cd "$srcdir"
- install -Dm 755 "ra_lsp_server-$_pkgver" "$pkgdir/usr/bin/ra_lsp_server"
+ install -Dm 755 "rust-analyzer-$_pkgver" "$pkgdir/usr/bin/rust-analyzer"
}