summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2aa66e9db33..80dff66567ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = rust-clippy
pkgdesc = A bunch of lints to catch common mistakes and improve your Rust code
- pkgver = 0.0.177
+ pkgver = 0.0.179
pkgrel = 1
url = https://github.com/rust-lang-nursery/rust-clippy
arch = i686
arch = x86_64
license = MPL2
+ makedepends = rust-nightly
makedepends = cargo-nightly
makedepends = rustup
- depends = rust-nightly
+ depends = gcc-libs
pkgname = rust-clippy
diff --git a/PKGBUILD b/PKGBUILD
index 8ff8c08ee472..cebc60fa3ae7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=rust-clippy
-pkgver=0.0.177
+pkgver=0.0.179
pkgrel=1
pkgdesc="A bunch of lints to catch common mistakes and improve your Rust code"
arch=('i686' 'x86_64')
url="https://github.com/rust-lang-nursery/rust-clippy"
license=('MPL2')
-depends=('rust-nightly')
-makedepends=('cargo-nightly' 'rustup')
+depends=('gcc-libs')
+makedepends=('rust-nightly' 'cargo-nightly' 'rustup')
build() {
rustup run nightly cargo install clippy --root "$srcdir/build" --vers $pkgver --force
}