summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6d2c72d26dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rust-clippy
+ pkgdesc = A bunch of lints to catch common mistakes and improve your Rust code
+ pkgver = 0.0.168
+ pkgrel = 1
+ url = https://github.com/rust-lang-nursery/rust-clippy
+ arch = i686
+ arch = x86_64
+ license = MPL2
+ makedepends = cargo-nightly
+ makedepends = rustup
+ depends = rust-nightly
+
+pkgname = rust-clippy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..655739ecd55c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: sum01 <sum01@protonmail.com>
+pkgname=rust-clippy
+pkgver=0.0.168
+pkgrel=1
+pkgdesc="A bunch of lints to catch common mistakes and improve your Rust code"
+arch=('i686' 'x86_64')
+url="https://github.com/rust-lang-nursery/rust-clippy"
+license=('MPL2')
+depends=('rust-nightly')
+makedepends=('cargo-nightly' 'rustup')
+build() {
+ rustup run nightly cargo install clippy --root "$srcdir/build" --vers $pkgver --force
+}
+package() {
+ mv "$srcdir/build" "$pkgdir/usr"
+ rm -f "$pkgdir/usr/.crates.toml"
+}