summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--docdir.patch42
3 files changed, 51 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6b2a9e31db9..2ed48b6ddf24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jul 1 21:30:11 UTC 2016
+# Sun Oct 2 20:46:52 UTC 2016
pkgbase = rust-git
pkgdesc = A safe, concurrent, practical language from Mozilla.
pkgver = 1.0.0.beta.2833.gb850046
@@ -27,6 +27,7 @@ pkgbase = rust-git
source = git+https://github.com/rust-lang/rust.vim.git
source = git+https://github.com/rust-lang/rust-mode.git
source = git+https://github.com/rust-lang/zsh-config.git
+ source = docdir.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -37,6 +38,7 @@ pkgbase = rust-git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = c440666dc08e503ffaad60e00a09dc35a532390a598c51c294cf0e05ebefdefdd21474eae74a50c9100a8d42a3cc6f3b84c4ef17cb7cbe850c0085fd72a4b33a
pkgname = rust-git
install = rust.install
diff --git a/PKGBUILD b/PKGBUILD
index 34bbea21d8fa..2c0115a0cea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,9 @@ source=("git+https://github.com/rust-lang/rust.git"
"git+https://github.com/rust-lang/rust.vim.git"
"git+https://github.com/rust-lang/rust-mode.git"
- "git+https://github.com/rust-lang/zsh-config.git")
+ "git+https://github.com/rust-lang/zsh-config.git"
+
+ docdir.patch)
_noclone=(compiler-rt jemalloc libc llvm hoedown rust-installer)
sha512sums=('SKIP'
'SKIP'
@@ -33,7 +35,8 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'c440666dc08e503ffaad60e00a09dc35a532390a598c51c294cf0e05ebefdefdd21474eae74a50c9100a8d42a3cc6f3b84c4ef17cb7cbe850c0085fd72a4b33a')
pkgver() {
cd rust
@@ -44,6 +47,7 @@ prepare() {
rm -rf -- "${_noclone[@]}"
cd rust
+ git apply -3 "$srcdir"/docdir.patch
_srcdest="$SRCDEST" perl -pi -- /dev/stdin .gitmodules <<'END'
if (m{(?<assignment> \s* url \s* = \s*) .* / (?<submodule> [^/]*?)(?:\.git)?$}x) {
my $local = "$ENV{_srcdest}/$+{submodule}";
diff --git a/docdir.patch b/docdir.patch
new file mode 100644
index 000000000000..43c8f7db76e5
--- /dev/null
+++ b/docdir.patch
@@ -0,0 +1,42 @@
+diff --git a/configure b/configure
+index 59a3c1c..84c64bf 100755
+--- a/configure
++++ b/configure
+@@ -683,7 +683,6 @@ valopt_nosave local-rust-root "/usr/local" "set prefix for local rust binary"
+ valopt_nosave host "${CFG_BUILD}" "GNUs ./configure syntax LLVM host triples"
+ valopt_nosave target "${CFG_HOST}" "GNUs ./configure syntax LLVM target triples"
+ valopt_nosave mandir "${CFG_PREFIX}/share/man" "install man pages in PATH"
+-valopt_nosave docdir "${CFG_PREFIX}/share/doc/rust" "install documentation in PATH"
+
+ # On Windows this determines root of the subtree for target libraries.
+ # Host runtime libs always go to 'bin'.
+@@ -1129,7 +1128,6 @@ putvar CFG_STDCPP_NAME
+ # a little post-processing of various config values
+ CFG_PREFIX=${CFG_PREFIX%/}
+ CFG_MANDIR=${CFG_MANDIR%/}
+-CFG_DOCDIR=${CFG_DOCDIR%/}
+ CFG_HOST="$(echo $CFG_HOST | tr ',' ' ')"
+ CFG_TARGET="$(echo $CFG_TARGET | tr ',' ' ')"
+ CFG_SUPPORTED_TARGET=""
+@@ -1811,7 +1809,6 @@ putvar CFG_ARMV7_LINUX_ANDROIDEABI_NDK
+ putvar CFG_I686_LINUX_ANDROID_NDK
+ putvar CFG_NACL_CROSS_PATH
+ putvar CFG_MANDIR
+-putvar CFG_DOCDIR
+ putvar CFG_USING_LIBCPP
+
+ # Avoid spurious warnings from clang by feeding it original source on
+diff --git a/mk/install.mk b/mk/install.mk
+index be21286..d2e5449 100644
+--- a/mk/install.mk
++++ b/mk/install.mk
+@@ -12,8 +12,7 @@ RUN_INSTALLER = cd tmp/empty_dir && \
+ sh ../../tmp/dist/$(1)/install.sh \
+ --prefix="$(DESTDIR)$(CFG_PREFIX)" \
+ --libdir="$(DESTDIR)$(CFG_LIBDIR)" \
+- --mandir="$(DESTDIR)$(CFG_MANDIR)" \
+- --docdir="$(DESTDIR)$(CFG_DOCDIR)"
++ --mandir="$(DESTDIR)$(CFG_MANDIR)"
+
+ install:
+ ifeq (root user, $(USER) $(patsubst %,user,$(SUDO_USER)))