summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--docs.patch13
3 files changed, 10 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ecbaac210ac..e6a23702aa54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 11 06:16:05 UTC 2017
+# Sun Oct 1 09:47:23 UTC 2017
pkgbase = rust-nightly
pkgdesc = A safe, concurrent, practical language
- pkgver = 1.22.0.2017.09.09
+ pkgver = 1.22.0.2017.09.29
pkgrel = 1
url = http://www.rust-lang.org/
arch = i686
@@ -14,7 +14,7 @@ pkgbase = rust-nightly
makedepends = python2
makedepends = curl
makedepends = llvm
- makedepends = jemalloc
+ makedepends = cargo
provides = rust
conflicts = rust
options = staticlibs
@@ -22,10 +22,11 @@ pkgbase = rust-nightly
options = !emptydirs
options = !makeflags
source = http://static.rust-lang.org/dist/rustc-nightly-src.tar.gz
- md5sums = 8ede6ee2dcce23024b8c60069f5423b3
+ md5sums = 68a8d3572dd4c59c0e39262d4b208132
pkgname = rust-nightly
depends = shared-mime-info
+ optdepends = rust-doc-git: language and API documentation
provides = rust
conflicts = rust
diff --git a/PKGBUILD b/PKGBUILD
index d5cec5bc7d19..7295c753ec15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgbase=rust-nightly
pkgname=('rust-nightly' 'rust-nightly-doc')
-pkgver=1.22.0.2017.09.09
+pkgver=1.22.0.2017.09.29
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='A safe, concurrent, practical language'
url='http://www.rust-lang.org/'
license=('MIT' 'Apache')
-makedepends=('libffi' 'perl' 'python2' 'curl' 'llvm' 'jemalloc')
+makedepends=('libffi' 'perl' 'python2' 'curl' 'llvm' 'cargo')
source=("http://static.rust-lang.org/dist/rustc-nightly-src.tar.gz")
options=('staticlibs' '!strip' '!emptydirs' '!makeflags')
conflicts=('rust')
provides=('rust')
-md5sums=('8ede6ee2dcce23024b8c60069f5423b3')
+md5sums=('68a8d3572dd4c59c0e39262d4b208132')
export RUSTFLAGS="$RUSTFLAGS -C link-args=-lffi"
build() {
@@ -31,12 +31,14 @@ build() {
package_rust-nightly() {
depends=('shared-mime-info')
+ optdepends=('rust-doc-git: language and API documentation')
provides=('rust')
conflicts=('rust')
cd rustc-nightly-src
DESTDIR="$pkgdir" python2 ./x.py install
rm -fr "$pkgdir"/usr/share/doc/rust/html
+ rm "$pkgdir"/usr/share/doc/rust/README.md
rm -f "$pkgdir"/usr/lib/rustlib/{components,manifest-rustc,manifest-rust-docs,rust-installer-version,install.log,uninstall.sh}
install -d "$pkgdir"/usr/share/licenses/rust-nightly/
diff --git a/docs.patch b/docs.patch
deleted file mode 100644
index fbe8921c7d2e..000000000000
--- a/docs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/mk/crates.mk b/mk/crates.mk
-index c7abf27..f68fc2a 100644
---- a/mk/crates.mk
-+++ b/mk/crates.mk
-@@ -78,7 +78,6 @@ DEPS_panic_abort := libc alloc
- DEPS_panic_unwind := libc alloc unwind
- DEPS_unwind := libc
-
--RUSTFLAGS_compiler_builtins := -lstatic=compiler-rt
-
- # FIXME(stage0): change this to just `RUSTFLAGS_panic_abort := ...`
- RUSTFLAGS1_panic_abort := -C panic=abort
- \ No newline at end of file