summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc56771b5aa..1d35700131b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = rusti-git
license = MIT
makedepends = git
makedepends = cargo
+ depends = readline
depends = rust
+ optdepends = rust-racer: for code completion
provides = rusti
conflicts = rusti
source = git+https://github.com/murarth/rusti.git
diff --git a/PKGBUILD b/PKGBUILD
index 0a6042dff9c6..fd133ae89b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,9 @@ pkgver=r121.13b5940
pkgrel=1
pkgdesc="REPL for Rust"
url="https://github.com/murarth/rusti"
-depends=('rust')
+depends=('readline' 'rust')
makedepends=('git' 'cargo')
+optdepends=('rust-racer: for code completion')
provides=('rusti')
conflicts=('rusti')
arch=('i686' 'x86_64')