summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1694f0b504d2..894325d366b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rustotpony-bin
pkgdesc = RusTOTPony — CLI manager of one-time password generators like Google Authenticator
pkgver = 0.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zebradil/rustotpony
arch = x86_64
license = MIT
provides = totp
conflicts = rustotpony
- source = https://github.com/zebradil/rustotpony/releases/download/0.4.1/totp-linux
+ source = rustotpony-bin-0.4.1::https://github.com/zebradil/rustotpony/releases/download/0.4.1/totp-linux
sha256sums = dcb96179a0748a96a44ab0e9b3da508825fe70acf457277d3aff5130335d9d35
pkgname = rustotpony-bin
diff --git a/PKGBUILD b/PKGBUILD
index b36750f5d3c3..190a86a3b244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: German Lashevich <german.lashevich@gmail.com>
-
-pkgver=0.4.1
-
-_binname=totp
-
+#
+# Source: https://github.com/zebradil/aur
+#
+# shellcheck disable=SC2034,SC2154
pkgname=rustotpony-bin
-_pkgname=${pkgname%-bin}
-pkgrel=1
-pkgdesc='RusTOTPony — CLI manager of one-time password generators like Google Authenticator'
-provides=(${_binname})
-conflicts=(${_pkgname})
+pkgver=0.4.1
+pkgrel=2
+pkgdesc="RusTOTPony — CLI manager of one-time password generators like Google Authenticator"
+url="https://github.com/zebradil/rustotpony"
arch=(x86_64)
-url="https://github.com/zebradil/${_pkgname}"
-license=('MIT')
-source=("${url}/releases/download/${pkgver}/${_binname}-linux")
+license=(MIT)
+conflicts=(rustotpony)
+provides=(totp)
+source=(rustotpony-bin-0.4.1::https://github.com/zebradil/rustotpony/releases/download/0.4.1/totp-linux)
sha256sums=('dcb96179a0748a96a44ab0e9b3da508825fe70acf457277d3aff5130335d9d35')
-
-package() {
- install -Dm755 "${srcdir}/${_binname}-linux" "${pkgdir}/usr/bin/${_binname}"
+package ()
+{
+ _binname=totp;
+ install -Dm755 "${srcdir}/${_binname}-linux" "${pkgdir}/usr/bin/${_binname}"
}