summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feada5cd68ff..d6f548db0237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rustotpony-bin
pkgdesc = RusTOTPony — CLI manager of one-time password generators like Google Authenticator
pkgver = 0.4.1
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/zebradil/rustotpony
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index a3c86b69913b..3efc393ea041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=rustotpony-bin
pkgver=0.4.1
-pkgrel=7
+pkgrel=8
pkgdesc='RusTOTPony — CLI manager of one-time password generators like Google Authenticator'
url='https://github.com/zebradil/rustotpony'
arch=(x86_64)
@@ -15,6 +15,7 @@ provides=(totp)
source=(rustotpony-bin-0.4.1::https://github.com/zebradil/rustotpony/releases/download/0.4.1/totp-linux)
package ()
{
+ set -eo pipefail;
_binname=totp;
install -Dm755 "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/bin/${_binname}"
}