summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b73ba19bad1..a720a11a72e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = rustup-git
pkgdesc = The Rust toolchain installer
- pkgver = 1.26.0.r131.gd4c68448
+ pkgver = 1.27.0.r15.g6e8769c7
pkgrel = 1
url = https://github.com/rust-lang/rustup
install = post.install
arch = x86_64
license = MIT
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = cargo
depends = curl
@@ -30,6 +30,7 @@ pkgbase = rustup-git
conflicts = rust-nightly-bin
conflicts = rustup
conflicts = rust-analyzer
+ options = !lto
source = rustup-git::git+https://github.com/rust-lang/rustup.git
source = list-proxy-names.rs
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2cbb8838031b..5c5394a09bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
pkgname=rustup-git
-pkgver=1.26.0.r131.gd4c68448
+pkgver=1.27.0.r15.g6e8769c7
pkgrel=1
pkgdesc="The Rust toolchain installer"
arch=('x86_64')
url="https://github.com/rust-lang/rustup"
-license=('MIT' 'Apache')
+license=('MIT' 'Apache-2.0')
depends=('curl')
makedepends=('git' 'cargo')
optdepends=('lldb: rust-lldb script'
@@ -20,6 +20,7 @@ install='post.install'
source=("${pkgname}::git+https://github.com/rust-lang/rustup.git" "list-proxy-names.rs")
sha512sums=('SKIP'
'fdc9750850e8265409f2fcacf3c7f59e82b619ed40cef0c82944e08c17266107327813fb283c909b3b0821501fac064d9e3618060d688aa7c76cf16a36244626')
+options=(!lto)
pkgver() {
cd "$srcdir/${pkgname}"